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1 Getting Started

1.1 Welcome to FontCreator 7.5

Introduction

FontCreator allows you to create and edit TrueType, OpenType and Web Fonts.

The editor lets you easily select and modify the entire character set of any TrueType® font
and fonts based on OpenType® font technology. Features include the ability to convert
images to outlines, thus enabling you to create fonts with your own signature, logo and
handwriting.

The intuitive interface makes FontCreator the perfect tool for both new and experienced
users. The advanced validation features make the design process easy and help you avoid
common mistakes.

Key features

Create and edit TrueType and OpenType fonts

Opening and exporting of fonts in WOFF file format

OpenType Layout Features

Redesign existing characters

Add missing characters

Convert vector and raster based images (e.g. a signature, logo or handwriting) to

character outlines
Edit or regenerate font names

Fix character mappings

Generate, modify and clean up kerning pairs

Correct fonts that display incorrectly

Add or correct composite glyphs

Transform individual glyphs or an entire font (e.g. to make a bold version)

Split TrueType Collection or Extract TrueType Fonts from TrueType Collection

Preview fonts before installing

Install fonts in Windows

Make sure you have the latest version of FontCreator:

http://www.high-logic.com/ 

1.2 What's New in FontCreator 7.5

New features in this version of FontCreator 7.5 include:

Scalable color glyph support
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New features in this version of FontCreator include:

Completely redesigned overview window

Opening and exporting of fonts in WOFF file format

OpenType Layout Features

Project based font editing

More operations have Undo/Redo support

Support for Jumplists and Taskbar progress in Windows 7 and up

Optical Metrics

AutoHinting

1.3 Technical Support

Printed User Manual

If you prefer reading printed manuals, a PDF version of the entire help file is available through
the main menu (Help -> User Manual).

Online User Manual

The user manual is also available online:

http://www.high-logic.com/fontcreator/manual/index.html 

Forum

The forum is available to you for support and information about managing and designing
fonts. This forum has become a place where all users of FontCreator can share their
knowledge. Membership of the forum is free. There's a good chance other people have asked
the same questions as you, so you may be able to find the answers you need. Feedback and
suggestions are also welcome in the forum.

http://forum.high-logic.com/ 

Frequently Asked Questions

View the most frequently asked questions (and answers) about FontCreator here:

http://www.high-logic.com/fontcreator/faq.html 

1.4 Registration

Evaluation

During the trial period, FontCreator runs in Professional Edition mode and most features
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are enabled. After using FontCreator for a 30-day trial period, you must register and pay for it,
or remove it from your system. Registering makes your copy legal and helps support our
efforts to develop innovative products to best serve your needs. Thank you for your support of
FontCreator!

Why Register?

Registration allows you to continue using FontCreator 7.5 and entitles you to the following
benefits:

All future versions of FontCreator 7.x.

Direct e-mail support from the developers.

Three Editions

FontCreator is available in 3 editions. A home edition for personal use which can't be used for
commercial use. A standard edition that will suit most font designers. And a professional
edition to get the most out of your fonts. To view the differences between the FontCreator
editions see the comparison chart:

http://www.high-logic.com/font-editor/fontcreator/comparison.html 

To Register

The quickest and most convenient way to register is online via credit card. Other supported
payment methods like checks and cash are also supported. For more details take a look at
our registration page:

http://www.high-logic.com/register.html 

1.5 Credits

FontCreator contains several unmodified libraries that are available under the MPL.

VirtualShellUtilities from http://www.mustangpeak.net/;

ADOM from http://philo.de/xml/

FontCreator also uses an unmodified version of TTFAutohint which is available under the
FTL.

Portions of this software are copyright © 2013 The FreeType Project (www.freetype.org).  All
rights reserved.
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2 Quick Start Tutorial

2.1 Your First Font -- a Brief Tutorial

The quickest way to introduce yourself to FontCreator is to make a font. To make it personal
we will describe how to make a font of your own handwriting.

On the File menu, click New Project to start a new font project and create a font.

It is important to give our handwriting font a personal name, otherwise we will not be able to
identify (and install) the font properly. The font name is not the same as the filename (for
example timesbd.ttf has Time New Roman Bold as the font name, where Times New
Roman is the font family name and Bold is the font style).

To give our font a name we type "My Handwriting" in the Font family name field and press the 
OK button.

Now you will see the Font Overview window. All cells have a caption and to give you a visual
guidance, most cells contain a sample character shown as light grey outlines. Sample
characters don’t really exist in the font, you have to add glyph data yourself. In this tutorial we
will add this data for glyphs mapped to characters 3, A and B.
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2.2 Edit a Glyph - Character 3

From the Glyph Overview window we double-click on the cell with the caption "3". Now we
see the corresponding Glyph Edit window. Choose Freedraw Contours in the Insert
menu. During this operation a left mouse-click draws and a right-click erases . 

Press the Convert to contours button to convert the freedraw image to contours.

The contours should stay within the visible area, this area is defined by the WinAscent and
WinDescent reference lines and the left and right bearings (vertical dashed lines). Make sure
the glyph is within this area, parts outside this area will most likely be invisible. The left and
right bearings can be changed by dragging them to their desired position. The glyph should
be positioned between these lines, otherwise characters will overlap each other.

We close the Glyph Edit window to return to the Glyph Overview window.
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2.3 Edit a Glyph - Character A

From the Glyph Overview window we double-click on the cell with the caption "A". Now we
see the corresponding Glyph Edit window. Choose Contour in the Insert menu. During this
operation a left mouse-click creates a point onto the contour and a right mouse-click creates
a point off the contour (used to create a Bézier curve). 

Press the Apply button (or click on the first point) to finish the contour. We create two
contours in order to complete the glyph.

Contours that need to be filled black must have a clockwise direction. If we want to make a
white area inside an existing contour we must make the direction of the new contour counter
clockwise.

Finally make sure the contours are within the visible area (as described in the previous
section); if necessary adjust the left and right bearings.

We close the Glyph Edit window to return to the Glyph Overview window.

2.4 Edit a Glyph - Character B

To personalize character "B" we want to import an image of our own handwritten "B". This
image should not be too small or too large, we recommend an image dimension of 300x300
pixels. Bitmap, GIF, PNG and JPG images can be created with a paint program and if you
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have a scanner you could also import an image of your character "B" into the appropriate
software. 

From the Glyph Overview window we double-click on the cell with the caption "B". Choose
Import Image in the Tools menu. Press the Load button to select the image you want to use
and press the Generate button. Now you will see your image in the Glyph Edit window.
Finally make sure the contours are within the visible area (as described in the previous
section); if necessary adjust the left and right bearings.

2.5 Test and Install the Font

Now we have finished the first three characters we want to see the result. We test the new
font by selecting Test in the Font menu. Type upper case "A" and "B" and number "3" in the
text field to see your creation.
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To make your font available to other applications select Install in the Font menu. The Font
Installation wizard will guide you through the installation process. 

At the end of the installation process you will be informed that the font is installed
successfully. Almost all applications (like Word) immediately allow you to use the font, but
sometimes an application requires a restart before they recognize the newly installed font.
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When you are satisfied with the font, you need to export and install it.
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3 About Fonts

3.1 TrueType

TrueType is a scalable font technology designed by Apple Computer, and has been
superseded by the OpenType format. However people still refer to TrueType fonts, while in
fact 99.9% of all fonts that come with Windows are OpenType fonts.

See also:http://forum.high-logic.com/viewtopic.php?f=5&t=1619

A TrueType font file contains data, in table format, that comprises an outline font. Rasterizers
use combinations of data from the tables contained in the font to render the glyph outlines.

3.2 OpenType

The OpenType font format is an extension of the TrueType font format, allowing support for
PostScript font data. Technically there are two OpenType Font flavors; TrueType based (.ttf)
and PostScript based (.otf). OpenType was developed jointly by Microsoft and Adobe to
produce a hybrid between Type 1 and TrueType fonts, with additional features that work on
Macintosh and Windows computers. OpenType fonts can include the OpenType Layout
tables, which allow font designers to design better international and high-end typographic
fonts.

Some descriptions (of various fields in this document) are copied from the specification
available online at:

http://www.microsoft.com/typography/otspec/ 

3.3 Color Extension

As revealed at the Microsoft Build Developer Conference in June 2013, the Windows 8.1
Preview comes with a revolutionary extension to the OpenType font standard, which
introduces multi-color fonts. The technology which is both simple and powerful uses multi-
layer glyphs which are in essence scalable outlines that are rendered and processed like any
other character, except each layer has its own color.

FontCreator is the first (and of this writing, the only) font editor to support the new multi-color
fonts extension.

The beauty of the color extension, is that the fonts will continue to work like any other font on
devices and systems that don’t support the extension yet. That is why it is strongly
recommended to always include the base outlines for each glyph (used as fallback in case
color fonts are not supported, or not wanted in a particular situation).
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3.4 Web Open Font Format (WOFF)

The Web Open Font Format (WOFF) is a font format based on the same principles as
OpenType and TrueType fonts but has been optimized for use in web pages. WOFF is
supported across all recent major browsers. Fonts that are used in webpages are also called
"web fonts".

FontCreator supports both importing and exporting of WOFF fonts.

More information about Webfonts and how to use them:

http://www.webfonts.com 

More information about the Web Open Font Format:

http://www.w3.org/TR/WOFF/ 

3.5 Font Copyright

Unless you know otherwise, you should assume all fonts to be copyrighted works that are
someone's property and treat them as you would any other software. Fonts are software
products in their own right, and are protected by international copyright law as well as
individual license agreements. Even redistributing so-called 'freeware' or 'public domain' fonts
is problematic. If you have created a font yourself (without using anything from other fonts), it
is your property.

The use of any commercial font is governed by the terms of its manufacturer's End User
License Agreement (EULA). Several major font vendors specifically allow altering a font, as
long as the altered font is only used on machines for which you have licensed the original
font. If you have questions about what can or can't be done with a font, you should contact
that font's manufacturer. 

The Copyright Notice field in the Legal tab on the Font Properties dialog may direct you to
the copyright holder, but be aware that this field may be blank, or may have been altered. Also
the License Agreement and the License Agreement Link fields from the might have important
information.
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4 Opening, Creating and Saving Fonts

4.1 Working with Font Projects

FontCreator uses its own file format to store the font data, several other settings and
configuration parameters:

  

Font data

Font properties

Export settings

Guideline, Grid and Metrics settings

OpenType Layout Features

User notes

This will make sure that regardless of the font format you export, all information about the font
will remain available.

Opening existing project files

There are several ways to open existing project files:

Select Open project from the File menu

Select a recent project from the Reopen submenu in the File menu

Select a recent project in the Windows Taskbar Jumplist (only available on Windows 7 and

later)

Double-click a project file in the Windows Explorer

Drag a project file from the Windows Explorer onto FontCreator

4.2 Open a Font

There are several ways to open a font file.

Open fonts already installed on your system

To open an installed font file select Open from the File menu and choose Installed Font
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option.

Open any font that is available

From the File menu, select Open and choose Font File option to open a font through
Windows default open dialog box.

Drag and drop a font file

Another way to open a font, is to drag a font file from Windows Explorer and drop it onto
FontCreator.

Reopen a font file

To open a font that you've used recently, choose Reopen from the File menu to display the
names of the last ten used fonts. Click on the font you want to use.

Warning: If you want to open fonts that are located in Windows fonts folder you should use the Installed
Fonts command (or drag and drop), because this folder is marked (by Windows) to be a special folder
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and therefore behaves differently (e.g. it shows font names instead of file names).

Warning: Really large fonts can only be loaded when your system has enough internal memory.

4.3 Create a Font Project

On the File menu, click New Project to create a new font.

Font family name

In Windows, the Font family name is displayed in the font menu. The Font family name will
appear as the font name when you select a font in a word-processing program, etc.

Font style

The font will be identified through its Font family name and the Font style. In order to create
a full font family, you will need to create four fonts, each with a different Font style, but with
the same Font family name.

Predefined outlines

Selecting "Include outlines" will add outlines for several common characters. This will speed
up creating your new font. You can replace or modify these glyphs later. The outlines can be
used royalty free in your own fonts.

Note: On the Naming tab, accessed by Tools -> Options, there are default naming values,
that will be added to the new font.

See also:

Default Naming Values
Insert Characters
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4.4 Save a Project

To save an active project select Save Project in the File menu. If you want to save the
active project with a different name, or in a different location, select Save Project As in the
File menu, choose a name and location and click Save.

4.5 Export a Font

To export an active project to a TTF/OTF or WOFF font select one of the export formats in
the Export submenu in the File menu. The first time you export your font you will be asked to
choose an output location and review the export settings.

Output File
Location where the file will be exported. If this field is left blank, FontCreator will show a save
dialog the first time you export the font.

Warning: It is not recommended to export your font directly into the Windows fonts folder.
Warning: Files locked by Windows can't be saved. This happens when the Operating System
keeps the font in memory. You could try to uninstall (delete) the font through the Windows
fonts folder.
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Include Glyph Names
Whether or not to include Glyph names in the font. It is recommended to include them in
TrueType/OpenType fonts but they can be omitted in WOFF fonts to reduce the file size.

Include OpenType Features

No - No OpenType Layout Features are embedded in the font.
Default Script - Common OpenType Layout Features are automatically added to your font
based on the available glyphs. 
Custom Script - The features defined in the OpenType Layout Features Editor are
embedded into the font.

Note: OpenType Layout Features are ignored for Symbol Fonts.
Note: Custom Script is not available in the Home Edition of FontCreator and will revert to
Default Template

Include Kerning
No - No kerning information is added to the font
KERN - Kerning is added to the font using the legacy 'kern' table
GPOS - Kerning is added to the font using the newer 'gpos' table
KERN and GPOS - Kerning is added to the font using both the 'kern' and 'GPOS' table.
Newer computer systems will use the 'GPOS' kerning while systems that do not support
'GPOS' can use the legacy 'kern' table.

Generate Hinting
Hinting information will improve readability on screen for smaller font sizes.
No Hinting - No hinting is added to the font
Autohinting - Hinting information is automatically generated
Keep Original - Stores hinting information that was originally available in the font.

Include Metadata (Web Font only)
If enabled, a small xml file is embedded in the font that allows web browsers to identify the
font without having to load the entire font.

4.6 Close a Font

To close the current font or project select Close in the File menu. To close all active fonts
and/or projects at once select Close All in the File menu.
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5 Editing Fonts

5.1 Editing Options

5.1.1 Undo Command

The Undo command from the Edit menu reverses the last action made to the active font.

Using Undo returns the font to its state prior to the most recent operation. The number of
operations you can undo depends on the settings from the Tools menu in the Edit tab of the
Options dialog box. 

Note: The Undo button on the toolbar has a small arrow which allows you to pull down a
menu and select multiple actions to be undone.

5.1.2 Redo Command

The Redo command from the Edit menu re-applies the actions or commands on which you
have used the Undo command. FontCreator supports Multiple Redo, which is particularly
useful if you have removed more edits and commands than you had intended. If this occurs,
and you want to re-apply them, either choose the Redo command as many times as is
necessary or use the drop arrow on the Redo button located on the Standard toolbar.

Note: The Redo button on the toolbar has a small arrow which allows you to pull down a
menu and select multiple actions to be redone.

5.1.3 Repeat Your Last Action

When you select Repeat from the Edit menu the program will repeat the last action you have
done. When the Repeat command can't be selected, you can't repeat the last action.

5.1.4 Finding a Glyph

You can search for glyphs and or characters by their glyph name and mappings. Select Find
on the Edit menu to open the Find window or use the keyboard shortcut CTRL+F. 

The input field accepts several kinds of keywords:



Editing Fonts 23

© 1997 - 2013 by High-Logic B.V. All rights reserved.

Single character : Entering a single character will find the entered character if it exists in the

font. (Example: "a") Note that this type of search is case-sensitive regardless of the case-
sensitive checkbox!

Part of glyph name

Start with: "A*" will return Agrave Aacute etc.

Ends with: "*grave" will return Agrave Ugrave etc.

"#353" will show that exact Glyph ID

Unicode ranges $0032-$0046, $0012  etc (can be entered in decimal or hexadecimal)

5.1.5 Tags

Tags allow you to mark glyphs so they appear with a small colored bar in the glyph
overviews. To tag a glyph, right click on one or more selected glyphs and select one of the
tags from the Tag submenu, use the keyboard shortcut keys (CTRL + 1-5) or drag and drop
them from the glyph overview window onto one of the tag categories. You can view all glyphs
that have a tag by selecting the Tagged category from the categories panel or select one of
the tag subcategories to view all glyphs that have a specific tag assigned to them.

Note: Each glyph can only have 1 tag.

5.2 Editing Fonts

5.2.1 Using the Glyph Overview

In the Font Overview window there is a list of categories and a grid where all cells have a
caption and a part that shows the glyph.
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The categories panel is a convenient way to quickly show a subset of characters or glyphs
and allows you to display them in several groupings and orderings. To change the current
grouping and ordering use the Overview Toolbar on the main toolbar.

When creating Unicode fonts, the categories panel shows a convenient list of all Unicode
blocks that contain at least one mapped glyph. When you add new characters through the 
Add Characters dialog or change character mappings the Unicode categories are
automatically updated. If you are creating a symbol font, a symbol category will be shown
instead.

Each cell has a caption that is used to display the glyph name, Unicode name, the code-
points or the glyph index. To select the kind of caption, use the Overview Toolbar or right-
click in the Glyph Overview window and select a specific caption. You can switch between
decimal and hexadecimal values for the code-points and glyph indexes in the Display
Format submenu of the View menu.

The Autocaption feature allows you to view the actual value of the current selected grouping.
This means that when you group by Advance Width, the cell captions display the Advance
Width value.
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5.2.2 Used By

The Used By window (available by right-clicking a glyph in the Glyph Overview window or
Glyph Edit window and selecting the Used By menu item) is used to display an overview of
all glyphs that use the selected glyph. To jump directly to one of the displayed glyphs double-
click it in the window or select it and click the OK button.
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5.2.3 Insert Characters

Select Characters in the Insert menu to add glyphs with their character mappings and glyph
names to the font. This option is available only when the Glyph Overview window is active.

Select a Unicode block from the droplist, "Go to Unicode Block". Uncheck the "Sorted" field to
sort the blocks in numerical code-point order instead of alphabetical order. if necessary,
choose another installed font which includes the characters to be added. Characters can be
added anyway, but it helps if the glyphs can be previewed.
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Use the next and previous block or next and previous plane buttons to scroll through the font.
The code point of the character to add can be found by entering the decimal value in the "Go
to Code Point" field, or by entering the hexadecimal value preceded by a dollar sign. For
example, enter 8364 or $20AC to find the Euro Sign (€). The Unicode name of the character
can be used in the field, "Find Part of Character Name". For example, type "euro" to first find
"EURO-CURRENCY SIGN," then "EURO SIGN" with Find Next.

Click on a character to select it and preview it in the glyph preview at bottom left. Double-click
the character, or click the Add button, to add its code-point to the list of selected characters at
the bottom of the dialog. Keep adding individual characters by double-clicking, or hold down
the Shift key and double-click to add a range of characters. The code-points will be displayed
in Hexadecimal or Decimal notation depending on the setting in View -> Display. You can
also type code-points into the characters to add field, separated by commas (or hyphens to
add a range of characters), or cut and paste a predefined list of characters from a text file.
For example, pasting 256-383 then clicking OK would add the entire Latin Extended-A
character set.

Click OK to dismiss the dialog and add the characters to the current font. If the glyphs exist in
the overview sample font, and if "Show samples in empty glyphs" is on, grey outlines of the
new characters will be displayed in the glyph overview.

Characters or entire character sets can also be added using Transform Scripts. See the
topic: Glyph Transformer.

Note: The number of glyphs that may be included in one font is limited to 65535.

See also:

Glyph Transformer

5.2.4 Insert Glyphs

Select Glyphs in the Insert menu to add glyphs to the font. This option is available when the
Glyph Overview window is active.

Note: The number of glyphs that may be included in one font is limited to 65535.
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5.2.5 Copy and Paste Glyphs

The Paste Special command is used to specify what parts of a group of glyphs (already
copied to the clipboard) should be pasted.

You can select any number of glyphs in the Glyph Overview window by clicking on them
while holding down the Ctrl key. You can perform several operations on the selected glyphs.
If you paste the selection to another font the glyphs will be pasted to the selected glyphs. If
you want the pasted glyphs to be placed in another position you can select the same number
of glyphs you copied prior to the paste action, or select just one glyph.

Outline Data will copy the outlines.

Metrics are the Left Side Bearing and Advance Width of each glyph

Glyph Name will paste all glyph names

Code-points will paste the mappings. Keep same code-points adds new mappings to the
glyphs. Mappings that already exist will be reassigned to the pasted glyph(s) when the 
Overrule same code-points option is selected. You can also choose to add mappings. Add
code-points adds all mappings. When mappings are already available, they will be
reassigned to the pasted glyph(s).

5.2.6 Adding a New Character - the EURO Sign

Sometimes a font is missing one or more characters. This will explain how to add the EURO
sign to an existing font.

There are two ways to add a character to a font. The easiest and recommended way is
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explained first:

1a. Add a character at the end of the glyph list (recommended)
Select Characters from the Insert menu. Enter "EURO SIGN" into the Find Part of
Character Name and press the Find Next button. Now select the Add button and press
the OK button.

1b.  Add a glyph at the end of the glyph list
Select Glyphs from the Insert menu and insert one glyph after the last glyph.

Give the glyph a proper Name and Code-point
Open the Glyph Properties tool window (View -> Glyph Properties or shortcut F3) and
enter "Euro" as Glyph Name.

Click the Generate button  next to the code-points to automatically fill in the proper
code-point.

Click the Apply button to assign the changes

2. Edit the glyph
Double-click the Euro glyph to open the Glyph Edit window. There are several ways to
add contours to the glyph:

Freedraw contours (Insert -> Freedraw Contours...)

Import an image (Tools -> Import Image)

Add new contours (right-click and select "New Contour...")

Paste contours from other glyphs

Drag outlines from the Samples toolbar

3. Adjust the right and left bearings
Around the glyph there are four lines that represent the Bearings. These are shown by
default but you can hide them through the Show Bearings button on the Drawing
toolbar. The left and right bearings can be changed by dragging them to their desired
position.

You could also adjust the bearings from the Glyph Properties tool window.

4. Test the font.
Select Test in the Font menu.
Add a Euro sign in the text area with Alt-0128 or use MainType utility to copy and paste
the EURO character into the text area.

5.2.7 Font Name

Be careful not to confuse the font name with the file name. Windows uses the file name to
install a font, while the font name is used to identify the font.

To change the font name select Properties from the Font menu.
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5.2.8 Font Type

To change the font type (for example from Regular to Bold) you need to change a few
settings on the Font Properties dialog:

Font Subfamily, Weight on the Identification tab

Bold and Italic checkboxes on the Identification tab

Italic Angle on the Identification tab

PANOSE Weight to on the Characteristics tab

5.2.9 Font Embedding

Select Properties from the Font menu and select the Legal tab page. Here you can alter
the Font Embedding Licensing Rights.

Note: Embedding symbol fonts may not be possible in Word.
Note: In order to embed a font, the Glyph Names must be exported for some applications (like
Adobe Acrobat).

5.2.10 Monospaced versus Proportional

A monospaced font is a font where all characters have the same width. These fonts are often
used to emulate typewriter output for reports, tabular work and technical documentation.

In a proportional font the width of each character, including the space character, varies with
the shape of the character. Proportional fonts are easier to read and are preferred for
publishing applications. 

From proportional to monospaced

To change a proportional spaced font into a monospaced font, follow these steps:

Select the AutoMetrics command (Tools menu) to force the advance width to be the

same for all glyphs (except for the second glyph normally called .null - this glyph's advance
width should be zero).

If necessary, change the outlines of glyphs that are too wide.

In the Properties dialog (Font menu) on the Characteristics tab set Family Kind to 2

(Latin Text) and Proportion to 9 (Monospaced).

The Fixed Pitch will be automatically set to the correct value.

5.2.11 Unicode versus Symbol

When a font has a Windows Unicode BMP (UCS-2) platform, the font is a normal font.
When a font has a Windows Symbol platform, the font is a Symbol font.

Symbol character sets have a special meaning: all of the characters in the Unicode range
0xF000 - 0xF0FF (inclusive) will be used to enumerate the symbol character set. All glyphs in
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this range are mapped to the range 0x0000 - 0x00FF.

Symbol fonts do not form words so line breaks can occur after any character code. A spell
checker should not check symbol font-formatted material.

You can convert your font between Unicode and Symbol though the Convert Font menu
item in the Tools menu.

Note: only the first 224 characters of symbol fonts will be accessible: a space and up to 223
printing characters.

5.2.12 Recommended Glyphs

In addition to script and language specific punctuation and native numbers, the following
glyphs are highly recommended for inclusion in fonts.

First four glyphs

TrueType outline fonts should have the following four glyphs at the beginning of a font. These
were listed in Apple's original TrueType specification. These glyphs are recommended to
allow for the same version of the font to work on both Windows and Macintosh.

Glyph 0 is the .notdef (missing character) glyph.

Glyph 1 is the .null glyph; it has no contours and zero advance width.

Glyph 2 is the nonmarkingreturn glyph; it has no contours and positive advance width.

Glyph 3 is the space (and no-break space) glyph; it has no contours and positive advance
width.

Index Glyph Name Unicode

0 .notdef

1 .null

2 nonmarkingreturn

3 space $0020
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Glyph 2 and 3 should have the same advance width.

The .notdef glyph is very important for providing the user feedback that a glyph is not found in
the font. This glyph should not be left without an outline as the user will only see what looks
like a space if a glyph is missing and will not be aware of the active font's limitation.

It is recommended that the shape of the .notdef glyph be either an empty rectangle, a
rectangle with a question mark inside of it, or a rectangle with an "X". Creative shapes, like
swirls or other symbols, may not be recognized by users as indicating that a glyph is missing
from the font and is not being displayed at that location.

General punctuation and 'Latin' numbers

Glyph Name Descriptive Name Sample Unicode

space space  $0020

exclam exclamation mark ! $0021

quotedbl quotation mark " $0022

numbersign number sign # $0023

dollar dollar sign $ $0024

percent percentsign % $0025

ampersand ampersand & $0026

quotesingle apostrophe ' $0027

parenleft left parenthesis ( $0028

parenright right parenthesis ) $0029

asterisk asterisk * $002A

plus plus sign + $002B

comma comma , $002C

hyphen hyphen-minus - $002D

period period . $002E

slash slash / $002F

zero digit zero 0 $0030

one digit one 1 $0031

two digit two 2 $0032
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three digit three 3 $0033

four digit four 4 $0034

five digit five 5 $0035

six digit six 6 $0036

seven digit seven 7 $0037

eight digit eight 8 $0038

nine digit nine 9 $0039

colon colon : $003A

semicolon semicolon ; $003B

less less-than sign < $003C

Quotes and Ellipsis

Smart quotes (also known as curly quotes) are fancy characters which make text look better
compared to the straight apostrophe (') and straight quote or inches character ("). Microsoft
Word also automatically changes 3 periods to an ellipsis.

If your font does not support these characters, you can either turn the "Smart Quotes" and
"Ellipsis" features off in the application (In Microsoft Word it's under Tools -> AutoCorrect) or
make sure these glyphs and their mappings are available in the font.

Glyph Name Descriptive Name Sample Unicode

quoteleft left single quotation mark ' $2018

quoteright right single quotation mark ' $2019

quotedblleft left double quotation mark " $201C

quotedblright right double quotation mark " $201D

ellipsis horizontal ellipsis … $2026

Other suggested glyphs

Glyph Name Descriptive Name Sample Unicode

nbspace * no-break space  $00A0

currency currency sign ¤ $00A4

section section sign § $00A7
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logicalnot not sign ¬ $00AC

degree degree sign ° $00B0

paragraph paragraph sign ¶ $00B6

periodcentered middle dot • $00B7

endash en dash – $2013

emdash em dash — $2014

bullet bullet • $2022

euro euro currency symbol € $20AC

bulletoperator ** bullet operator • $2219

* nbspace is usually mapped to the space glyph

** bulletoperator is usually mapped to the periodcentered glyph

5.3 Editing Glyphs

5.3.1 Introduction

From the Glyph Overview window you can double-click a glyph in order to open a Glyph
Edit window and edit the selected glyph. You can also select a glyph, right-click it and select
Edit.

You can "zoom in" to get a close-up view of your glyph or "zoom out" to see more of the page
at a reduced size.  You can use the edit field located on the Drawing toolbar to change the
zoom percentage. The Zoom to Selected button will be enabled as soon as contours or
points are selected. Pressing this button will zoom into the current selection. When you press
the Fit to Window button, the glyph will be shown with the largest zoom factor that also
shows the ascender and descender lines.

There are three glyph types:

Empty glyphs

Some glyphs don't have any outlines, like the glyph that represents the space character.
However empty glyphs, like all types, do have bearings (a space character has an advance
width like any character).
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Simple glyphs

A simple glyph consists of a series of contours. A contour is defined by a series of points.
In order to distinguish between contour and point related operations, you can choose to
work in contour or point mode. At any time you can change between Contour and Point
mode; select the appropriate Mode from the View menu or press one of the triangle
buttons on the Drawing toolbar.

Contours
To select an external contour of a black area of a glyph click within the black area. To select
an internal contour of a black area click within the internal white area.

To select more than one contour, press and hold down the Shift key while selecting
contours. Another way is to click on the workspace above and to the left of where the
contours are and, while holding down the left mouse button, drag a rectangle around all
contours you want to select simultaneously.

Use the Ctrl-A shortcut or select Select All from the Edit menu to select all contours.
While holding down the Shift key and clicking a contour already selected, will remove that
contour from the current selection.

Points
To select a single point click on it. To select more than one point hold down the Shift key
while clicking on several points or another way is to hold down the left mouse button and
drag a rectangle around the points you want to select simultaneously, whether a few or all
points in the glyph. Use the Ctrl-A shortcut or select Select All from the Edit menu to
select all points. Hold down the Shift key and select points you want to add to or remove
from the current selection.

Composite glyphs

Composite glyphs are simply a combination of two or more other glyphs - usually, but not
limited to, a base character and one or more diacritical marks that are placed above and/ or
below the base character.

To select a composite member click on it. If you want to modify specific member data
double-click a composite member to open the Composite Glyph Properties window.

Other parts of the manual have a comprehensive explanation of the three glyph types.
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5.3.2 Glyph Metrics

Several horizontal and vertical lines, also known as glyph metrics, will help you with your font
design. You can activate them through the Metrics Options window.

In order to change the metrics click Properties on the Font menu and then click the Metrics
tab.

In the Glyph Edit window there are two vertical lines (normally the glyph outline lies in between
these lines) that represent the left and right side bearings. These are shown by default but
you can hide them through the Show Metrics button on the Drawing toolbar. The left and right
side bearings can be changed by dragging them to their desired position. You can also adjust
the bearings through the Glyph Properties tool window. White space should be evenly
distributed between the left and right side bearings of glyphs except when font is specifically
designed with ligatures for joining characters in a cursive script font.

Note: Lining numbers (i.e. the digits 0 - 9) should all have the same advance width.

Tip: In the Glyph Edit window you can step through with the Back and Forward blue arrows
in the Drawing toolbar to make adjustments.

See also:

Metrics Options

5.3.3 Empty Glyphs

Empty glyphs (like the space glyph) don't have outlines but they do have an advance width. In
a Glyph Edit window you can change an empty glyph into a simple glyph by adding contours.
You can also change an empty glyph into a composite glyph by adding a Composite Glyph
Member.

5.3.4 Simple Glyphs

5.3.4.1 Introduction

In a TrueType font, glyph shapes are described by their outlines. A glyph outline consists of a
series of contours. Contours are composed of straight lines and curves. Curves are defined
by a series of points that describe second order Bézier-splines. The TrueType Bézier-spline
format uses two types of points to define curves, those that are on the curve and those that
are off the curve. Any combination of off and on curve points is acceptable when defining a
curve. Straight lines are defined by two consecutive on curve points.
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Contours that need to be filled black must have a clockwise direction. If we want to make a
white area inside an existing contour we must make the direction of the new contour counter
clockwise. Contour direction is determined by seeing in which direction the point index
values increase or decrease. Contour direction is from the smaller point index to the larger.
The general rule is that the contour direction should be such that "black is on the right". Using
the glyph "O" as an example, the outer contour should travel clockwise, and the inner contour
counter clockwise.

Click the Correct contour directions button on the Validation toolbar to correct the
direction of all misoriented contours in a simple glyph or select Direction from the Edit menu
to change the direction of the selected contour(s).
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The character "4" is represented by a glyph with two contours. One contour you see as the
black area and the white area within this glyph is the other contour. 

From the Drawing toolbar you can change the way you can modify the glyph. In the Glyph
Edit window, you can change between Contour and Point mode by double clicking inside the
edit area, select the Mode from the View menu or use the appropriate button on the Drawing
toolbar. The main difference between Contour mode and Point mode is that in Contour
mode all operations are related to the contours while in Point mode you can change parts of
the contours (e.g. move, add and delete points).

Holding down the Shift key while dragging points or contours restricts movement so the
selection moves only in the x or y direction.

In the Glyph Edit window (in Point mode) the rectangles represent on curve points and the
circles off curve points.
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Tip You can nudge the selected contour(s) or point(s) up, down, left, or right by pressing the
arrow keys. By holding down the Ctrl key and pressing the arrow keys finer nudging is
available. By holding down the Shift key and pressing the arrow keys bigger nudging is
available.

5.3.4.2 Contours

You can perform several operations on contours while in Contour mode.

Select contours

To select more than one contour, hold down the Shift key while selecting contours. Another
way is to click on the workspace where no contours are and, while holding down the left
mouse button, drag a rectangle around all contours you want to select simultaneously. Use
the Ctrl-A shortcut to select all contours.

Resize selected contours

When you select one or more contours, a box with "resizing handles" shows up around the
selected contour(s). Click and drag one of those resizing handles to change the size of the
selected contour(s). By default the selected contour(s) remain proportional to the original
size, as you resize it. Press the Shift key while you drag one of the resizing handles located
at the corners to resize freely.

Move selected contours

To constrain a selection so it moves only horizontally or vertically, press Shift as you drag the
selection. Press Alt to ignore the snap to grid and snap to guidelines features.

Duplicate selected contours

To copy selected contours to a new position, hold down the Ctrl key as you drag the
selection. Hold the Alt key to ignore the snap to grid and snap to guidelines features. Hold
down the Shift key to move only in vertical or horizontal direction. Any combination of these
keys is allowed.

Rotate selected contours

You can rotate by first selecting a contour (or more) and then select it again (don't double-
click). The little rectangles on the corners have changed into circles. These can be used to
rotate the selected contour(s). The other four rectangles are used to skew the selection. To
change the origin for the rotation you can move the little cross in the middle of your selection.
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There are several ways to add outlines (contours) to a glyph:

Using the Freedraw Contours tool

Select the Add rectangle or Add ellipse button on the Drawing toolbar and place it on the

Glyph Edit window.
Draw a new contour

First select Contour from the Insert menu. A left mouse click creates a point on the
contour and a right mouse click creates a point off the contour for a bézier curve. Creating
points while holding down the Ctrl key generates straight lines (horizontal or vertical). After
you have created your contour you press the Apply button.
Samples toolbar:

Drag and drop a glyph from the Samples toolbar into a Glyph Edit window.
Copy contours from other glyphs, even from other fonts and paste them. (These operations

carried out in their respective Glyph Overview windows)
Import a stored vector or bitmap file of an image of a glyph into a Glyph Edit window using

Import in the Tools menu.
Paste a Clipboard image of a glyph into the Glyph Edit window. The Clipboard image could

be created in another application which has graphics editing capabilities e.g. a cropping
function. This operation is performed using the Paste option in the Edit menu.
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5.3.4.3 Points

In Point mode the rectangles represent on curve points and the circles off curve points.

Select points

To select a single point click on it. To select more than one point hold down the Shift key
while clicking on several points or another way is to hold down the left mouse button and drag
a rectangle around the points you want to select simultaneously, whether a few or all points in
the glyph. Use the Ctrl-A shortcut to select all points. Hold down the Shift key and select
points you want to add or remove from the current selection.

Move selected points

To constrain a selection so it moves only horizontally or vertically, press Shift as you drag the
selection. Press Alt to ignore the snap to grid and snap to guidelines features.

There are several operations related to points (move, add, delete, change points to on or off
curve, etc.). Select one or more points and then right-click one of them to open a sub-menu
with even more point related features.

Every contour has a start point with a green mark and an end point with a red mark. To
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change the start point, right-click a point and select First Point.

5.3.4.4 Join and Split Contours

Both Contour mode and Point mode have ways to combine and split contours. Usually Union,
Intersection and Exclusion, available in Contour mode, and Knife, available in both modes,
are recommended. If these features don't give expected results the two remaining features
(Join Contours and Split Contour) available in Points mode might help.

Union, Intersection and Exclusion in Contour mode

Use the Union feature to merge several overlapping contours.

Use the Intersection feature to keep all overlapping parts.

Use the Exclusion feature to remove all overlapping parts.

Knife in both modes

Use the Knife feature to split contours.

Join Contours and Split Contour in Point mode

When you want to combine two contours you have to select one point on each contour. Next
right-click one of these points and click "Join Contours" on the shortcut menu. 

To split a contour into two contours, select two points (these points should not be neighbors)
on the same contour and then right-click one of these points and click "Split Contour" on the
shortcut menu.

Note: Make sure the two combining contours have the same direction.

Note: Union, Intersection, Exclusion and Knife are not available in the Home Edition of
FontCreator.

5.3.4.5 Freedraw

The Freedraw tool can be used to manually draw lines that can be converted into contours.
To enter Freedraw mode select Freedraw Contours from the Insert menu, or  select the
Freedraw tool from the Drawing Toolbar.
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When the Freedraw tool is active, the Freedraw toolwindow will be visible. On this
toolwindow you can set the Brush width, delete the last stroke or convert the drawn lines into
contours.

To draw straight horizontal or vertical lines you can holding down the shift while drawing.

To erase part of the drawing, you can use the right mouse button as an eraser tool.

When you're satisfied, click on “Convert to contours” to add the contour to the currently
displayed glyph (contours cannot be added to composite glyphs). To cancel, just close the
Free Draw dialogue with the close button.

The new contour will not be joined to existing contours, even if it was drawn crossing them.

5.3.5 Composite Glyphs

5.3.5.1 Introduction

Composite glyphs are simply a combination of two or more other glyphs - usually, but not
limited to, a base character and one or more diacritical marks that are placed above and/or
below the base character.

Create composite glyphs

You can create a composite glyph when you are editing an empty glyph in a Glyph Edit
window. To add a composite glyph member select Glyph from the Insert menu. To add one
or more glyphs as composite glyph members first copy glyphs from the Glyph Overview
window and then paste them into a Glyph Edit window that contains an empty glyph or a
composite glyph.

Move selected glyph members

You can change the position of each of the used glyphs within the Glyph Edit window.

To constrain a selection so it moves only horizontally or vertically, press Shift as you drag the
selection. Press Alt to ignore the snap to grid and snap to guidelines features.

Transformations

Besides moving glyph members, it is possible to perform operations like scale and rotation by
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double-clicking on the glyph member or right-clicking and select Glyph Member Properties
.

Duplicate selected glyph members

To copy selected composite glyph members to a new position, hold down the Ctrl key as you
drag the selection. Hold the Alt key to ignore the snap to grid and snap to guidelines features.
Hold down the Shift key to move only in vertical or horizontal direction. Any combination of
these keys is allowed.

Convert to simple glyph

To convert a composite glyph to a simple glyph select the glyph in the Glyph Overview
window or in the Glyph Edit window and select Make Simple from the Edit menu.

Join composite glyph members

If composite glyph members intersect such as with C cedilla, Get Union of Contours on
the Glyph toolbar will convert the composite glyph to a simple glyph and join intersecting
contours into one contour.
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5.3.5.2 Add Glyph Member

If you wish to edit an empty glyph or modify a composite glyph you can select Glyph from
the Insert menu.

In the Select Composite Glyph Member window select the glyph you want to add to the
composite glyph and press the OK button.
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5.3.5.3 Glyph Member Properties

When you have opened a composite glyph in the Glyph Edit window, you can modify the
properties of each composite glyph member. Either double-click a  Glyph Member or right-
click it and then select Glyph Member Properties.

In the Composite Glyph Properties window you can modify the position, scale, rotation,
transformation and special flags of the selected member. Use the Previous and Next
buttons to walk through the members.

The Flags consist of a set of fields:

Use this glyph's metrics

If set, this forces the advance width and left side bearing (and right side bearing) for the
composite to be equal to those from this original glyph. This works for hinted and unhinted
characters. Only one member can have this option selected. Without this flag, the actual left
side bearing and right side bearing of the composite glyph will be used.

Round xy to grid

Round the x and y offsets.

No overlap

This bit is reserved/obsolete. Do not set it.



Editing Fonts 47

© 1997 - 2013 by High-Logic B.V. All rights reserved.

Overlap compound

Used by Apple in GX fonts.

Scaled component offset

Composite designed to have the component offset scaled (designed for Apple rasterizer).

Unscaled component offset

Composite designed not to have the component offset scaled (designed for the Microsoft
TrueType rasterizer).

Note that the behavior of the Use this glyphs metrics operation is undefined for rotated
composite components. 

5.3.5.4 Complete Composites

Use the Complete Composites feature to add composite glyph members to your glyphs. To
use this powerful feature, select a glyph, or a range of glyphs, right-click and select 
Complete Composites. The selected glyphs will be composed using data in
CompositeData.xml, which is read when FontCreator first uses the feature. This feature
works with over two thousand glyphs that are defined in this file. To get the most out of this
feature follow these guidelines:

The selected glyph(s) must be mapped with a Windows Unicode mapping. 

If the selected glyph(s) are empty or simple they will be replaced wherever composites

are defined. Do not include simple glyphs in your selection if you don't wish to
replace them with composites. 
If the selected glyph(s) are already composites they will be replaced only if the composite

glyph members are different, not if their positions or scale factors are different.
All composite members must be present in the font. If any composite members are

mapped, but still empty, the composite glyph will be completed, though obviously missing
the contours that have not been defined yet.

Info: Read the documentation about the content of the file CompositeData.xml and an
explanation about how to modify and add glyphs. This document is available from our
website:

http://www.high-logic.com/fcptutorials.html 

Note: Complete Composites is not available in the Home Edition of FontCreator.
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5.3.6 Color Glyphs

5.3.6.1 Introduction

Each glyph can have it's own color information assigned to it. If a host application does not
support the color font extension, the regular outlines will be shown.  There are a couple of
similarities with making a composite glyph, but there are also several differences.

Create a single color glyph

The easiest way to create a color version of a glyph, is to select the "Colorize" option from the
right-click menu when editing a glyph. This will automatically add the current glyph and assign
a single color to it.

Create a multi-color glyph

To make a multi-color glyph, you need to add other glyphs and then define a color for each of
these color members. Unlike composite glyph members, you can’t change the size or
position of these color members. You will need to make sure the individual glyphs are all
designed to fit into the color glyph. One other important requirement, is the fact that the
metrics of the base glyph and the color members must be the same. So the offset (usually
set to 0) as well as the advance width have to match.

Switching between color and normal mode

When editing a glyph, click the "Color Mode" button  or select Color Mode from the View
menu.

5.3.6.2 Add Glyph Member

To add one or more Color Glyph members, make sure you are in Color Mode and right-click

in the Glyph Edit window and select Add or click the Add icon . 
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In the Select Color Glyph Member window select the glyphs you want to add to the color
glyph and press the OK button.

You can change the order of the color glyph members via the up and down buttons on the 
Color Glyph Member toolbar, the Order options in the right-click menu or via the Alignment
toolbar. To show and/or hide toolbars, select Toolbars on the View menu.

5.3.6.3 Palettes and Colors

A font can contain one or more palettes that allow a host application to quickly change the
color scheme. By using palettes you can make different color schemes that allow your font to
use different colors with, for example a different background color.

The palette colors are global, so if you change a color which is assigned to several color
members, then all those members will use the updated color.If you want a unique color for a
specific color glyph member, then add a color to the palette and use that instead. 

When in Color Mode you can assign colors to specific members, by selecting the Paint

Bucket tool  from the Drawing Toolbar and click on one of the color glyph members in
the Glyph Edit window. You can change the current color by clicking on one of the palette
entries in the Palette Toolbar.
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See also:

Palette 

5.4 Format

5.4.1 Properties

5.4.1.1 Identification

Global and horizontal layout information about the font is found on the Identification page (
Font Properties window). On the Font menu, click Properties, and then click the
Identification tab.
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Font Family

The name the user sees. Maximum length is 31 characters.

Font Subfamily

The name of the style.

Width

Indicates a relative change from the normal aspect ratio (width to height ratio) as specified by
a font designer for the glyphs in a font.

Note: Although every character in a font may have a different numeric aspect ratio, each
character in a font of normal width has a relative aspect ratio of one. When a new type style
is created of a different width class (either by a font designer or by some automated means)
the relative aspect ratio of the characters in the new font is some percentage greater or less
than those same characters in the normal font -- it is this difference that this parameter
specifies.

Weight

Indicates the visual weight (degree of blackness or thickness of strokes) of the characters in
the font.

Italic Angle

Italic angle in degrees from the vertical. Zero for upright text, positive for text that leans to the
right (forward).

Font revision

Set by the font manufacturer.

Note: For historical reasons, the Font revision version is not used by Windows to
determine the version of a font. Instead, Windows evaluates the version string from the 
Version String field.

Created

The date and time the font was created, press the Now button to set these fields to the
current date and time.

Modified

The date and time the font was last modified, press the Now button to set these fields to the
current date and time.
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Automatically update modified timestamp when exporting font

When checked, the timestamp will be automatically set to the current date and time when
you export a font.

Generate the following naming fields automatically (recommended)

When checked, the Full Font Name, Version String, Unique Font Identifier and
PostScript Name fields are automatically updated

5.4.1.2 Extended

The Extended page is used to alter the Additional Naming and Additional Font Styles
fields. On the Font menu, click Properties, and then click the Extended tab. 

Preferred Family (Windows only)

In Windows, the Family name is displayed in the font menu; the Subfamily name is presented
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as the Style name. For historical reasons, font families have contained a maximum of four
styles, but font designers may group more than four fonts to a single family. The Preferred
Family and Preferred Subfamily IDs allow font designers to include the preferred family/
subfamily groupings. These IDs are only present if they are different from fields Font Family
name and Font Subfamily name.

Preferred Subfamily (Windows only)

In Windows, the Family name is displayed in the font menu; the Subfamily name is presented
as the Style name. For historical reasons, font families have contained a maximum of four
styles, but font designers may group more than four fonts to a single family. The Preferred
Family and Preferred Subfamily fields allow font designers to include the preferred family/
subfamily groupings. These fields are only present if they are different from fields Font Family
name and Font Subfamily name.

WWS Family

The WWS Family name *

WWS Subfamily

The WWS Subfamily name *

PostScript CID Findfont Name

Its presence in a font means that the Postscript name field in the Naming window holds a
PostScript font name that is meant to be used with the "composefont" invocation in order to
invoke the font in a PostScript interpreter.

This field must be restricted to the printable ASCII subset, codes 33 through 126, except for
the 10 characters: '[', ']', '(', ')', '{', '}', '<', '>', '/', '%'.

Compatible Full (Macintosh only)

On the Macintosh, the menu name is constructed using the FOND resource. This usually
matches the Full Name. If you want the name of the font to appear differently than the Full
Name, you can insert the Compatible Full Name in this field. 

Sample Text

This can be the font name, or any other text that the designer thinks is the best sample to
display the font in. 

*) For more information about WWS please visit our forums at http://forum.high-logic.com or
visit this website: http://blogs.msdn.com/b/text/archive/2007/04/23/wpf-font-selection-model.
aspx

5.4.1.3 Legal

The Legal page is used to enter the Copyright, Trademark and Licensing information. On the
Font menu, click Properties, and then click the Legal tab. 
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Some Naming fields can be modified within the Edit Naming Field window accessed by
pressing the [...] button.

5.4.1.4 General

5.4.1.4.1  General

This page consists of a set of metrics. On the Format menu, click Settings, and then click
the General tab. 
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Contents and Layout Version

Version 3 updated Unicode Character Ranges.

Version 4 changed deprecated font direction hint.

Font Header Flags

This field is used to specify the global information about the font. Press the Edit button to
modify this field through the Font Header Flags window.

Units Per Em

Valid range is from 16 to 16384. This value should be a power of 2 for fonts that have
TrueType outlines. Nowadays 2048 units per em value is the best value for all fonts of any
size including large Latin or non-Latin script fonts. 
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This value is used to convert values in the pixel coordinate system by multiplying them by a
scale. This scale is: 

pointSize * resolution / ( 72 points per inch * units_per_em ) 

Smallest read. size

Smallest readable size in pixels. Most fonts have this value set to 9.

Subscript, horizontal

The recommended horizontal size in font design units for subscripts for this font. 

Subscript, vertical

The recommended vertical size in font design units for subscripts for this font. 

Subscript x offset

The recommended horizontal offset in font design units for subscripts for this font.

Subscript y offset

The recommended vertical offset in font design units from the baseline for subscripts for this
font. 

Superscript, horizontal

The recommended horizontal size in font design units for superscripts for this font.

Superscript, vertical

The recommended vertical size in font design units for superscripts for this font.

Superscript x offset

The recommended horizontal offset in font design units for superscripts for this font.

Superscript y offset

The recommended vertical offset in font design units from the baseline for superscripts for
this font.

Calculate

It is up to word-processing software to use these values for superscript and subscript effects.
However, be aware not all software use these values uniformly, so when the default
superscripts and subscripts look  correct in one application, they might look wrong in another
application. The calculate button calculates the values so that they look correct in Microsoft
Word 2010. 

Strikeout size

Width of the strikeout stroke in font design units. This field should normally be the width of the
em dash for the current font. If the size is one, the strikeout line will be the line represented by
the strikeout position field. If the value is two, the strikeout line will be the line represented by
the strikeout position and the line immediately above the strikeout position. For a Roman font
with a 2048 em square, 102 is suggested.
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Strikeout position

The position of the strikeout stroke relative to the baseline in font design units. The value of
strikeout position should not interfere with the recognition of standard characters, and
therefore should not line up with crossbars in the font. For a Roman font with a 2048 em
square, 460 is suggested.

Underline Position

Suggested values for the underline position (negative values indicate below baseline).

Underline Thickness

Suggested values for the underline thickness.

Note: Word processing applications decide whether they use these underlinePosition and
underlineThickness values or use their own defaults.
Warning: Some Word processors may crash when this value is set to zero.

Caret Offset

The amount by which a slanted highlight on a glyph needs to be shifted to produce the best
appearance. Set to 0 for non-slanted fonts.

5.4.1.4.2  Font Header Flags

The Font Header Flags give global information about the font.

Baseline for font at y=0

Set this field when the baseline for all glyphs is at y= 0 (that is, the x-axis).
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Left side bearing point at x=0

Set this field when the x-position of the leftmost black bit is assumed to be the left side
bearing.

Instructions may depend on point size

Set this flag when there are instructions that depend on point size. Instructions may use point
size explicitly in place of pixels per em. This means that scaling a 12 point screen font to
obtain the equivalent printer font may not produce the identical result as requesting a 12 point
printer font.

Force ppem to integer values for all internal scaler math

When this field is selected integer scaling will be used instead of fractional scaling. Fractional
ppem sizes may be used if this field is not selected.

Instructions may alter advance width

When this field is set it allows the font to alter device dependent widths (the advance widths
might not scale linearly).

Apple specific field 5

This field should be set in fonts that are intended to be laid out vertically, and in which the
glyphs have been drawn such that an x-coordinate of 0 corresponds to the desired vertical 
baseline.

Reserved

Reserved, do not check this field

Apple specific field 7

This field should be set if the font requires layout for correct linguistic rendering (e.g. Arabic
fonts).

Apple specific field 8

This field should be set for a GX font which has one or more metamorphosis effects
designated as happening by default.

Apple specific field 9

This field should be set if the font contains any strong right-to-left glyphs.

Apple specific field 10

This field should be set if the font contains Indic-style rearrangement effects.

Font data is 'lossless'

Set this flag when font data is 'lossless', as a result of having been compressed and
decompressed with the Agfa MicroType Express engine.
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Font converted

Set this flag when the font is converted (produce compatible metrics).

Font optimised for ClearType

Set this field if the font is optimised for ClearType

Reserved

Reserved, do not check this field

Reserved

Reserved, do not check this field

Note: The Apple specific fields should be set according to Apple's specification. However,
they are not implemented in OpenType.

5.4.1.5 Metrics

This page consists of a set of spacing fields and font design flags. On the Format menu,
click Settings, and then click the Metrics tab. 
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Typo Ascender

The typographic ascender for this font. Remember that this is not the same as the Ascender
value in the Metrics tab, which Apple defines in a far different manner.

The suggested usage for TypoAscender is that it be used in conjunction with unitsPerEm to
compute a typographically correct default line spacing. The goal is to free applications from
Macintosh or Windows-specific metrics which are constrained by backward compatibility
requirements. These new metrics, when combined with the character design widths, will
allow applications to lay out documents in a typographically correct and portable fashion. 

For CJK (Chinese, Japanese, and Korean) fonts that are intended to be used for vertical
writing (in addition to horizontal writing), the required value for TypoAscender is that which
describes the top of the design space (aka, em-square). For example, if the design space of
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the font extends from coordinates 0,-120 to 1000,880 (that is, a 1000x1000 box set 120
design units below the Latin baseline), then the value of TypoAscender must be set to 880.
Failing to adhere to these requirements will result in incorrect vertical layout. 

Typo Descender

The typographic descender for this font. Remember that this is not the same as the
Descender value in the Metrics tab, which Apple defines in a far different manner.

The suggested usage for Typo Descender is that it be used in conjunction with unitsPerEm
to compute a typographically correct default line spacing. The goal is to free applications from
Macintosh or Windows-specific metrics, which are constrained by backward compatibility
requirements. These new metrics, when combined with the character design widths, will
allow applications to lay out documents in a typographically correct and portable fashion.

For CJK (Chinese, Japanese, and Korean) fonts that are intended to be used for vertical
writing (in addition to horizontal writing), the required value for Typo Descender is that which
describes the bottom of the design space (aka, em-square). For example, if the design space
of the font extends from coordinates 0,-120 to 1000,880 (that is, a 1000x1000 box set 120
design units below the Latin baseline), then the value of Typo Descender must be set to -
120. Failing to adhere to these requirements will result in incorrect vertical layout. 

Typo Line Gap

The typographic line gap for this font. Remember that this is not the same as the Line Gap
value, which Apple defines in a far different manner.

The suggested usage for Typo Line Gap is that it be used in conjunction with Units per em
to compute a typographically correct default line spacing. Typical values average 7-10% of
units per em.

Win Ascent

The ascender metric for Windows. This, too, is distinct from Apple's Ascender value and
from the Typo Ascender value. Win Ascent is computed as the yMax for all characters in
the Windows ANSI character set. Win Ascent is used to compute the Windows font height
and default line spacing. For Symbol fonts, it is the same as yMax.

Win Descent

The descender metric for Windows. This, too, is distinct from Apple's Descender value and
from the Typo Descender value. Win Descent is computed as the -yMin for all characters
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in the Windows ANSI character set. Win Descent is used to compute the Windows font
height and default line spacing. For Symbol fonts, it is the same as -yMin.

Use typo metrics for line spacing

If set, it is strongly recommended to use Typo Ascender - Typo Descender + Typo Line
Gap as a value for default line spacing for this font. 

Ascender (Macintosh-specific)

Typographic ascent

Descender (Macintosh-specific)

Typographic descent

Line Gap (Macintosh-specific)

Typographic line gap. Negative Line Gap values are treated as zero.

Tip: To automatically calculate ascender and descender values press the Calculate button.

Additional Metrics

x-Height

This metric specifies the distance between the baseline and the approximate height of non-
ascending lowercase letters measured in Funits. This value would normally be specified by a
type designer but in situations where that is not possible, for example when a legacy font is
being converted, the value may be set equal to the top of the unscaled and unhinted glyph
bounding box of the glyph encoded at U+0078 (LATIN SMALL LETTER X). If no glyph is
encoded in this position the field should be set to 0. 

This metric, if specified, can be used in font substitution: the xHeight value of one font can be
scaled to approximate the apparent size of another. 

CapHeight

This metric specifies the distance between the baseline and the approximate height of
uppercase letters measured in Funits. This value would normally be specified by a type
designer but in situations where that is not possible, for example when a legacy font is being
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converted, the value may be set equal to the top of the unscaled and unhinted glyph bounding
box of the glyph encoded at U+0048 (LATIN CAPITAL LETTER H). If no glyph is encoded in
this position the field should be set to 0.

This metric, if specified, can be used in systems that specify type size by capital height
measured in millimeters. It can also be used as an alignment metric; the top of a drop capital,
for instance, can be aligned to the CapHeight metric of the first line of text. 

5.4.1.6 Ranges

5.4.1.6.1  Overview

The Ranges page on the Font Properties window has several fields related to character
ranges and additional metrics. On the Font menu, click Properties, and then click the
Ranges tab. 
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Unicode Character Ranges

This field is used to specify the Unicode blocks or ranges encompassed by the font file in the 
mappings for the Windows platform. The Ranges depend on the selected Content and
Layout version. Press the Edit button to modify this field through the Unicode Character
Range window or press the Calculate button the generate the value.

Code Page Character Ranges

This field is used to specify the code pages encompassed by the font file in the mappings for
the Windows platform. Press the Edit button to modify this field through the Code Page
Character Range window or press the Calculate button the generate the value.

Automatically update character ranges when exporting font (recommended)

When enabled the character ranges will be updated when the font is exported. This will make
sure that the ranges are always correct.

5.4.1.6.2  Unicode Character Range

This field is used to specify the Unicode blocks or ranges encompassed by the font file in the 
mappings for the Windows platform. If a Unicode range is selected it is considered
functional. The determination of "functional" is left up to the font designer, although character
set selection should attempt to be functional by ranges if at all possible.
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5.4.1.6.3  Code Page Character Range

This field is used to specify the code pages encompassed by the font file in the mappings for
the Windows platform. If the Windows platform is Windows Symbol, then the Symbol
Character Set should be selected.

If a code page is selected then the code page is considered functional. The determination of
"functional" is left up to the font designer, although character set selection should attempt to
be functional by code pages if at all possible.

Note: Symbol character sets have a special meaning. If the Symbol Character Set is
selected, and the font file contains a Windows Symbol platform, then all of the characters in
the Unicode range 0xF000 - 0xF0FF (inclusive) will be used to enumerate the symbol
character set. If this code page is not selected, any characters present in that range will not
be enumerated as a symbol character set.
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5.4.1.7 Characteristics

PANOSE

These fields are used to describe the visual characteristics of a given typeface. These
characteristics are then used to associate the font with other fonts of similar appearance
having different names. The PANOSE evaluation document details the specifications for
assigning PANOSE numbers.

http://www.panose.com/ 

Font Family Classification

These fields are a classification of the font-family design. 

The font class and font subclass are registered values assigned by IBM to each font family.
These fields are intended for use in selecting an alternate font when the requested font is not
available. The font class is the most general and the font subclass is the most specific. More
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information about this field is available online:

http://www.microsoft.com/typography/otspec/ibmfc.htm 

5.4.2 Font Information

5.4.2.1 Calculated Fields

Information about the font is found on the Font Information dialog (from the Font menu).

These fields can't be modified directly as they are calculated and depend on other font related
data, but you can double-click a row, to jump to the specific glyph.
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NumGlyphs

The number of glyphs in the font.

maxPoints

Maximum points in a non-composite glyph.

maxContours

Maximum contours in a non-composite glyph.

maxCompositePoints

Maximum points in a composite glyph.

maxCompositeContours

Maximum contours in a composite glyph.

maxZones

1 if instructions do not use the twilight zone (Z0), or 2 if instructions do use Z0; should be set
to 2 in most cases.

maxTwilightPoints

Maximum points used in Z0.

maxStorage

Number of Storage Area locations. 

maxFunctionDefs

Number of FDEFs.

maxInstructionDefs

Number of IDEFs.

maxStackElements

Maximum stack depth. This includes Font and CVT Programs, as well as the instructions for
each glyph. 

maxSizeOfInstructions

Maximum byte count for glyph instructions.

maxComponentElements

Maximum number of components referenced at "top level" for any composite glyph.

maxComponentDepth

Maximum levels of recursion; 1 for simple components.
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X Minimum for all glyph bounding boxes

Y Minimum for all glyph bounding boxes

X Maximum for all glyph bounding boxes

Y Maximum for all glyph bounding boxes

The bounding box values computed using only glyphs that have contours. 

advanceWidthMax

Maximum advance width value 

minLeftSideBearing

Minimum left side bearing value 

minRightSideBearing

Minimum right side bearing value

xMaxExtent

Maximum extent value 

usFirstCharIndex

The minimum Unicode index (character code) in this font, according to the Windows Unicode
BMP (UCS-2) or Windows Symbol mapping table. For most fonts supporting Win-ANSI or
other character sets, this value would be 0x0020.

usLastCharIndex

The maximum Unicode index (character code) in this font, according to the Windows
Unicode BMP (UCS-2) or Windows Symbol mapping table. This value depends on which
character sets the font supports. 

5.4.2.2 Unsupported Tables

Over the years the TrueType and OpenType font specifications have been updated with new
tables. FontCreator supports all common font tables

The preferred table ordering is defined in the file TableOffsetOrder.txt. Although this is the
recommended order for OpenType fonts with TrueType outlines in the Windows operating
system, you can add, remove and change the order of these tables.
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If you want to delete an unsupported table, select the table on the Unsupported Tables page
and press the Delete button.

5.4.3 OpenType Layout Features

5.4.3.1 Automatic OpenType Layout Features

FontCreator can automatically add a lot of common ligatures and other OpenType Layout
Features to your font. The only requirement is that your glyph names are properly set. For a
full list of features and their required glyph names please see the following website:

http://www.high-logic.com/fontcreator/otlf/features.xml
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5.4.3.2 OpenType Layout Feature Editor

The OpenType Layout Feature Editor allows you to take full control over all the supported
OpenType Layout Features in your font. Because adding features can be very time
consuming the editor uses a scripting language that is very easy to use and understand.

To test if the syntax is correct and all Glyph names are valid, select Compile in the Actions
menu, use the shortcut key F9, or click the button on the toolbar. If there are any syntax
errors or glyph names that could not be resolved the Output window will list them. You can
double-click on the error to quickly jump to the line where the error occurred.

The script is saved in your project file, but if you wish to save it to a separate file you can
choose Export Script... from the File menu.

Note: The OpenType Layout Feature Editor is not available in the Home Edition of
FontCreator

5.4.3.3 Advanced Editing

When a font is opened, the OpenType Layout Features are automatically decompiled and
stored as a script in your project. You can edit this script by opening the OpenType Layout



FontCreator Help72

© 1997 - 2013 by High-Logic B.V. All rights reserved.

Features editor via the Font -> OpenType Layout Features menu item.

You can extract the OpenType Layout Features from another font by choosing Extract script
from font... from the Tools menu in the OpenType Layout Features editor. 

Note: Advanced Editing Features are only available in the Professional Edition of
FontCreator

5.4.3.4 Examples and Help

For example scripts and help with creating custom scripts, please visit our forums at:

http://forum.high-logic.com/ 

5.4.3.5 Syntax

5.4.3.5.1  Basics

A script consist of several "blocks" containing declarations for scripts, features, lookups and
groups. A block is started by the keyword and optional name and/or tag following a left curly
bracket "{" a block is closed by a right curly bracket "}". 

It is not possible to nest these blocks with the exception of the language block which has to
be nested into a script block. Names of blocks must be unique across the script and they are
case sensitive. It is possible to reference a block before it is declared. A compiler error will be
generated when a feature is referenced that does not exist and when a feature is declared,
but not referenced. 

Basic layout of a script:

script <tag> {

  <feature references>

}

feature <name> <tag> {

  <lookup references>

}

lookup <name> {

  [featureflags <flags>] 

  <substitution declarations>

}

5.4.3.5.2  Supported substitutions

The OpenType Layout Feature specification describes 8 types of substitution. The following
table shows which ones are currently supported by FontCreator:

# Type Supported Description C
o
m
m
e
n
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t

1 Single Yes Substitute a single glyph by another single glyph
(a -> b)

2 Multiple Yes Substitute a single glyph by other multiple glyphs
(a -> xyz)

3 Alternate Yes Substitute a single glyph by one of multiple
alternates (a -> x or y or z) 

4 Ligature Yes Substitute multiple glyphs by a single ligature (f f i
-> ffi)

5 Context No

6 Chaining Context Partially Substitute context specific glyphs (3rd -> 3rd) O
n
l
y
g
r
o
u
p
b
a
s
e
d

7 Extension Substitution No

8 Reverse chaining
context single 

No

5.4.3.5.3  Comments

To add comments to your script, simply add a # (number sign) in front of it:

# This is comment

5.4.3.5.4  Feature

The feature keyword is used in 2 ways: To reference a feature and to declare a feature. A
feature is referenced from a script block to indicate the specified feature is available in that
script.

Referencing a feature:

script <tag> {

  feature MyLigatures; # referencing feature "MyLigatures"

}

Declaring a feature:

feature <name> <tag> {
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  <feature declaration>

}

Where:

name is a name you can create yourself. You may only only use a-z, A-Z, 0-9 and "_" in

your name. Names are case-sensitive, and may only be declared once.

tag is one of the feature tags defined on the Microsoft list of feature tags. A full list of

available tags can be found at http://www.microsoft.com/typography/otspec/featurelist.htm

5.4.3.5.5  Group

The group keyword is used to declare a group of glyphs to be used for Chained Context
Substitution.

group @<group name> [ <glyphs> ];

Where:

name is a name you can create yourself. You may only only use a-z, A-Z, 0-9 and "_" in

your name and it must start with an @ (at) sign. Names are case-sensitive, and may only
be declared once.

5.4.3.5.6  Language

The language keyword is used to include a feature into a specific language. All languages not
assigned to a specific language are available to ALL languages. The language keyword can
only be used inside a script block. Assigning a feature to a specific language:

script <scripttag> {

  language <tag> {

    <features>  # only available in this language

  }

  <features> # available in all languages

}

Where:

tag is one of the language tags defined on the Microsoft list of language tags (deprecated

languages are not supported). A full list of supported languages can be found at http://www.
microsoft.com/typography/otspec/languagetags.htm

5.4.3.5.7  Lookup

The lookup keyword is used in 2 ways: To reference a lookup and to declare a lookup. A
lookup is referenced from a feature block to indicate the specified lookup should be used for
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that feature. Lookups can also be referenced from Chained context lookups

Referencing a lookup from a feature:

feature MyLigatures liga {

  lookup <name>;

}

Referencing a lookup from a chained context lookup:

lookup MyChainedContextLookup {

  context (@BackTrackGroups) @InputGroups (@LookAheadGroups);

  sub 0 <lookup name>;

}

Declaring a lookup:

lookup <name> <tag> {

  <lookup declarations>

}

Note: It is possible to set optional lookup flags (properties) via the lookupflags keyword.

5.4.3.5.8  LookupFlags

The lookupflags keyword is used to modify several flags (properties) of a lookup. The
current supported flags are:

RightToLeft This bit relates only to the correct processing of the cursive attachment
lookup type (GPOS lookup type 3). When this bit is set, the last glyph in a
given sequence to which the cursive attachment lookup is applied, will be
positioned on the baseline. 

IgnoreBaseGlyp
hs

Skips over base glyphs

IgnoreLigatures Skips over ligatures

IgnoreMarks Skips over combining marks

UseMarkFiltering
Set

Indicates that the lookup table structure is followed by a MarkFilteringSet
field. The layout engine skips over all mark glyphs not in the mark filtering set
indicated.

Applying lookupflags to a lookup:

lookup MyLookupTable {

  lookupflags <flags>;

}

When you want to apply more than one flag to a lookup, simply separate them by spaces.

Note: Lookup flag names are case sensitive. 
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5.4.3.5.9  Script

The script keyword is used to declare a block of features for a specific script. When the
features are to be used for all scripts, the script "dflt" (default) should be used. 

script <tag> {

  feature <featurename>;

}

tag is one of the script tags defined on the Microsoft list of script tags. The proposed script

tags on that list are also supported. A full list of script tags can be found at: http://www.
microsoft.com/typography/otspec/scripttags.htm

5.4.3.5.10  Sub

The sub keyword declares a substitute. As explained in the supported substitution types
section there are several substitution types. Substitution declarations can only declared in
lookups. It is not possible to declare a substitution directly in a feature. Each lookup can only
have 1 type of substitution, this means that if you want to use several substitution types in a
single feature, multiple lookups have to be declared.

Declaring Single (Type 1) substitutions

lookup MyLookupTable {

  sub A -> a.smcp; 

}

Declaring Multiple (Type 2) substitutions

lookup MyLookupTable {

  sub ffi -> f f i; 

}

Declaring Alternate (Type 3) substitutions

lookup MyLookupTable {

  sub asterisk -> [asterisk asteriskmath uni2051 uni2042 uni203B uni273B];

}

Declaring Ligature (Type 4) substitutions

lookup MyLookupTable {

  sub f f i -> ffi; 

}

Declaring Chained Context (Type 6) substitutions

lookup MyLookupTable {

  context (@<backtrackgroups>) @<inputgroups (@<lookaheadgroups);

  sub 0 <substitution table>;

}

IMPORTANT: The order in which substitute declarations appear are also the the way they
are processed by applications supporting OpenType Layout Features. This means that in the
case of ligatures that:

lookup MyLookupTable {
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  sub f i -> fi;

  sub f f i -> ffi; 

}

is not the same as:

lookup MyLookupTable {

  sub f f i -> ffi; 

  sub f i -> fi;

}

and the latter declaration will have the proper result. Why? when the sequence "f i" is
encountered it will be replaced by the fi character and will no longer match the f f i sequence.
In the latter example "f f i" is matched before "f i" and the result is as expected. 

5.4.4 Kerning

5.4.4.1 Overview

Kerning is the reducing/increasing of the space allocated between two glyphs to make them
fit more comfortably. Sometimes you want the bearings to be different in special situations.
When you want to change the distance between two characters you could use kerning pairs.
For example the A and the V could be closer (AV) together than TV.

Not all Operating Systems and applications support kerning. If they don't support kerning they
simply ignore the kerning pairs. Many sophisticated word processors and most DTP
applications have kerning support.

You can use the Preview toolbar to test the kerning pairs. You can also install the font and
use an application that supports kerning.

Tip: Although the Test Font window doesn't support kerning, it does temporarily install the
font. The name of the temporarily installed font looks like FC Test Font 012345. So while the
Test Font window is open, you will be able to use the font in any application (e.g. Word).
However, when you open the Test Font window again you'll have to change the font's name
in the application, because the temporary font name always changes. 

In Microsoft Office Word select Font from the Format menu and select the Character
Spacing tab. There you can turn on kerning in Word by checking the kerning for fonts field.

Note: Kerning in Symbol fonts won't be used in Microsoft Word.

Select Kerning from the Format menu to open the Kerning window. Show or hide the grid
and bearing lines, or change the colors from the buttons at the top of the dialog. The advance
width of each glyph of the current kerning pair is shown with the side bearing lines.
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On the left side you can select a kerning pair from the list of already assigned kerning pairs.
Type a letter to go to the first kerning pair using that letter (this is case-sensitive). To change
the kerning value use the left/right cursor keys. Hold down Shift to increase the step from 10
funits to 100 funits, hold down Control to reduce the step to 1 funit. To use the mouse, drag
the second glyph of the kerning pair to the left or right with the hand cursor. You can also use
the scrollbar or change the value in the edit field. Using the scrollbar slider handle moves
along in units of 192. Clicking on the scrollbar between slider handle and end arrows moves
along in units of 10. Clicking on the end arrows moves along in units of 1.

Use the Import and Export buttons to load and save kerning pair information.

Press the Clean Up button, to remove all kerning pairs that have a kerning value of 0 as well
as all pairs that are made up with glyphs that are not connected to the Windows Unicode
BMP (UCS-2) platform.

To delete all kerning pairs at once, right-click on the list view and select Delete all or press
the Delete All button .

Press the New button to add new kerning pairs. Click the Delete button to remove the
selected kerning pair.
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Note: According to the official TrueType and OpenType specifications, the maximum number
of kerning pairs is 10920, but FontCreator does allow up to 65535 kerning pairs.

See also:

Automatic Kerning

5.4.4.2 New Kerning Pair

In the New Kerning Pair window select both left and right glyphs and press the OK button.
Now you can alter the kerning value for this new pair in the Kerning window.

See also:

Kerning - Overview
Automatic Kerning
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5.4.5 Smoothing

5.4.5.1 Overview

The Smoothing window contains information which describes the preferred rasterization
techniques for the typeface when it is rendered on grayscale-capable devices. It also has
some use for monochrome devices, which may use the table to turn off hinting at very large
or small sizes, to improve performance. 

If there are no ranges defined in a typeface, the rasterizer may apply default rules to decide
how to render the glyphs on grayscale devices. The rasterizer will  use the ClearType related
values, if ClearType is enabled.

Note: Grayscale rendering and smoothing was invented for screen output and will not be
used by printer drivers.

At very small sizes, the best appearance on grayscale devices can usually be achieved by
rendering the glyphs in grayscale without gridfitting. At intermediate sizes, gridfitting (also
known as hinting) and monochrome rendering will usually produce the best appearance. At
large sizes, the combination of gridfitting and grayscale rendering will typically produce the
best appearance. 
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To add a new range, press the Insert button. To remove a range, select it and press the
Delete button. To remove all ranges, right-click the list view and select Delete All.

5.4.5.2 Insert Range

In the Insert Range window set the Upper limit and optionally check the Standard and
ClearType fields and press the OK button.

See also:

Smoothing - Overview

5.5 Tools

5.5.1 Glyph Transformer

The Glyph Transformer wizard can be selected from the Tools menu. Glyph
transformations are scripts for changing the shape and size of glyphs, and for automating
other repetitive tasks.
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FontCreator comes with more than 40 powerful scripts. There are scripts that allow you to
change a font into an italic or bold version. Other scripts extend a font's range by adding
characters for Greek Extended, Eastern Europe, Vietnamese, Ligatures, Small Capitals, and
more. Each script contains descriptive comments and advice on how to use it.

These scripts can be modified to suit your needs, and you can compose custom scripts by
adding commands from the list of available features on the left. Save them to use again later
using the save icon, and load a saved script using the folder icon. Press the OK button to
execute the currently loaded script on the current glyph in the glyph edit window, on the
selected glyphs, or on the entire font.

Tip: Save the font and copy the selected glyphs before using the Transform wizard, as this
operation is not undoable.

Info: If you really want to take the most out of this feature, we encourage you to read the
document Using Glyph Transformations, available from our website:

http://www.high-logic.com/fcptutorials.html 

Note: The Transform wizard is not available in the Home Edition of FontCreator.
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5.5.2 AutoMetrics

5.5.2.1 Metrics

With the Automatic Metrics wizard (select AutoMetrics from the Tools menu), you can
generate the bearings for a selection of glyphs.

Optical

In Optical mode most common character pairs are analyzed to find the best optical space
before and after each character. Please note that this process can take between several
minutes up to several hours.

The advance width for digits can be calculated in 2 modes:

Tabular 

All digits have the same advance width

Proportional

All digits have their own advance width

This feature is not available in the Home and Standard editions of FontCreator.
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Fixed Bearings

In Fixed Bearings mode the white spaces before and after the selected glyphs will be
modified. You can select the glyphs in step 2.

Fixed Width

In Fixed Width mode the advance width will be modified so all selected glyphs have the exact
same with. This is especially useful to convert a proportional font into a monospaced font.
You can select the glyphs in step 2.

Note: Fixed is also useful for the digit characters (0 to 9), which should all have the same
advance width.

5.5.2.2 Glyph Selection

In the left hand panel you see the glyphs which are present in your font. The right hand panel
will contain the glyphs which you select for modification of bearings.

Use the buttons located between the two panels of glyphs to move glyphs:

The top button will transfer all glyphs from the left hand panel to the right hand panel. This

is useful if many glyphs need modification. The unwanted can be selected and returned to
the left panel.
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The second button transfers only selected glyphs from the left panel to the right panel for

modification.
The third button returns only selected glyphs from the right panel to the left panel. These

glyph bearings, perhaps, require no modification.
The bottom button will transfer all glyphs from the right panel to the left panel.

Press the Finish button to return to the Glyph Overview window to check the result.

5.5.3 AutoKern

5.5.3.1 Setup

With the Automatic Kerning wizard (select AutoKern from the Tools menu), you can
generate kerning pairs for a selection of glyphs.

Warning: Although it is possible to add kerning pairs to a symbol font, it is not recommended.

Kerning pair selection

Select glyphs to be used for the Automatic Kerning wizard manually, or load them from file.

Note: The Import kerning pairs from file option is not available for symbol fonts.

Existing kerning pairs

Select the appropriate field.
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The Next button takes you to the next where you can select glyphs or import kerning pairs
from file.

Note: The Automatic Kerning wizard is not available in the Home Edition of FontCreator.

See also:

Kerning - Overview

5.5.3.2 Import

This step is used to import kerning pairs from file. Press the [...] button to select the file with
the kerning pairs.

Two kerning pair files are available from the kerning folder. If you are editing a basic font
(mostly ASCII characters) then you can use the standard kerning definition (KerningStandard.
txt) and more advanced fonts should use the extended one (KerningExtended.txt).

You can also create a kerning definition file from an existing font by opening the font and
export the kerning pair information through the Kerning dialog.

Format should be <First Glyph ASCI I  Character or Unicode Value><Second Glyph ASCI I
Character or Unicode Value><carriage return or space><The rest of the line is ignored>

Because Character \ is used as prefix for hexadecimal Unicode values, the ASCII character \
should be placed twice to distinguish between them. For example:

\\\2019 is a \ followed by a quoteright

\20195 is a quoteright followed by digit 5.
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Tip: To generate a kerning pair file with a list of kerning pairs from another font, open this
particular font and go to Kerning window from the Format menu and press the Save as
Text button.

The Next button takes you to the next page.

5.5.3.3 Glyph Selection

This step is used to manually select glyphs used by the next steps in this wizard. In the left
hand panel you see the glyphs which are present in your font. The right hand panel will
contain the glyphs which you select for modification of the kerning pairs.
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Use the buttons located between the two panels of glyphs to move glyphs:

The top button will transfer all glyphs from the left hand panel to the right hand panel. This

is useful if many glyphs need modification. The unwanted can be selected and returned to
the left panel.
The second button transfers only selected glyphs from the left panel to the right panel for

modification.
The third button returns only selected glyphs from the right panel to the left panel. These

glyph bearings, perhaps, require no modification.
The bottom button will transfer all glyphs from the right panel to the left panel.

The Next button takes you to the next page where changes to the automatic kerning settings
can be made.

5.5.3.4 Kern

In this step, enter the values for white space between glyphs and the minimum absolute
kerning value. 
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The White space between glyphs value is the recommended distance between two glyphs.
The minimum absolute kerning value is used to ignore kerning pair values less than this
value. Select Allow for positive kerning values if you also accept positive kerning pair
values. On this page you can also decide when existing kerning pairs should be changed.

Press the Next button to see a preview of the result.
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5.5.3.5 Preview

On this page there is a summary of the calculated kerning pairs.

Click the Finish button when you to accept the new kerning pairs, otherwise click the Back or
Cancel button.

Note: The Automatic Kerning wizard is not available in the Home Edition of FontCreator.

5.5.4 Import Images

5.5.4.1 Import Raster Image

Import image can be selected from the Tools menu when you have activated a Glyph Edit
window or it can be selected from the context menu after right-clicking in the window.



Editing Fonts 91

© 1997 - 2013 by High-Logic B.V. All rights reserved.

When you click on the Load button you get an open dialog box where you can open an image
file (recommended image dimension between 100x100 and 500x500 pixels). The image will
be displayed on the left and there will be a bitmap that is going to be used for the conversion
on the right. There are some filters and other operations you can apply to the source image
before starting the conversion.

The Threshold level is used to convert a color image into a black and white image. The
Threshold level is the lightness value above which colors are turned black. All colors with
lightness values above the level are turned into black. At a Threshold level of 1, all colors
except white change to black.

Check the Negative image field to invert the image.

Dilation causes objects to grow in size and erosion causes objects to shrink. The amount
that they grow or shrink depends upon the value specified on the right of the selection box. 
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Use the Smooth Filter to smooth the image. This will usually reduce the number of generated
points.

When the Import Mode is set to Trace, the image will be converted with curves. This is the
recommended setting. In case you don't want curves (especially useful for bar code fonts
and pixel fonts), set the Import Mode to Pixels.

Check the Default field to save the current settings as the default for each new import.
These settings are also used when pasting an image from the clipboard. Choosing to press
the Cancel button will retain these default settings.

Use the settings on the Glyph tab to position and resize the generated contours.

When you press the Generate button the conversion will start.

Tip: You can also paste an image from the clipboard or drag and drop image(s) from explorer
into the Glyph Overview and Glyph Edit windows.

Note: You can't import images into composite glyphs.

5.5.4.2 Import Vector Image

Import image can be selected from the Tools menu when you have activated a Glyph Edit
window or it can be selected from the context menu after right-clicking in the window. When
you open a vector based image file, the file will be instantly imported.

Tip: You can also paste an image from the clipboard or drag and drop image(s) from explorer
into the Glyph Overview and Glyph Edit windows.

Note: You can't import images into composite glyphs.

5.5.5 Sorting Glyphs

To change the order of the glyphs within a font select one of the options from the Sort
Glyphs submenu in the in the Tools menu.

No matter which option you select, these glyphs (if available) will always come first in the new
order.

.notdef

.null
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.nonmarkingreturn

Unicode Code-points

Glyphs will be sorted by these rules:

Glyphs are sorted by their Windows mappings

Then all remaining glyphs are sorted by their glyph names

The Unicode code points are retrieved from the Windows Character to Glyph Index Mappings.

Glyph names

Glyphs will be sorted by these rules:

The glyphs are sorted by their Glyph names

Then all remaining glyphs are sorted by their Windows mappings

Glyph type (empty, simple, composite)

Glyphs will be sorted by these rules:

The glyphs are sorted by their glyph type

Then all remaining glyphs are sorted by their Windows mappings

Alphanumeric

Glyphs will be sorted by these rules:

The glyphs are sorted by their mapped character. This features uses default compare

functions as used in Windows.
Then all remaining glyphs are sorted by their Windows mappings

5.5.6 Generate Glyph Names

Generate Glyph Names will generate glyph names for all glyphs with a known code-point. 

Note: You can manually add your own glyph names by editing the "glyphnames.dat" file in
your application data folder: "%appdata%\FontCreator\glyphnames.dat"

5.5.7 TrueType Collection

A TrueType Collection file is one or more fonts (TrueType or OpenType) combined into one
file. The Extract TrueType Fonts from TrueType Collection wizard, available from the
Tools menu, can extract those fonts.
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Source file

Select the TrueType Collection file.

Destination folder

The extracted font files will be saved in this folder.

Destination file prefix

The extracted files start with this prefix.

Here you will see all fonts available in the TrueType Collection. Select the fonts you want to
extract and press the Finish button.

5.5.8 External Tools

To quickly access MainType, Windows Fonts folder and Character Map select Launch
Externals from the Tools menu and select the tool you want to open.
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5.6 Printing

5.6.1 Print Font

This option (select Print in the File menu) is available when the Glyph Overview window is
active. If a Glyph Edit window is active you will be able to print a glyph.

You can choose what kind of font information you want to print:

Glyphs

Properties

Kerning pairs

Print Glyphs

Print all or the selected glyphs. 

Print Properties

Print all fields from the Font Properties window.

Print Kerning pairs

Print all kerning pairs, also available from the Kerning window.

5.6.2 Print Glyph

Select Print in the File menu to print a single glyph. This option is available when a Glyph
Edit window is active. If the Glyph Overview window is active you will be able to print the
font.
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The print options allow you to print the grid, points and bearings, and you can choose to fill the
outlines.

5.7 Font Validation

5.7.1 Setup

Designing glyphs can be very complicated. The Font Validation wizard, available from the
Font menu, identifies common potential problems and if possible points you to the specific
item (e.g. glyphs, contours and coordinates). It validates all glyphs and optionally fixes
detected problems.

The specific validation test are explained here:

Duplicate components

This problem will be reported when validating composite glyphs with two or more identical
glyph members.
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Empty components

This problem will be reported when validating composite glyphs with empty glyph members.

Duplicate contours

This problem will be reported when validating simple glyphs with two or more identical
contours.

Contours with one or two points

This problem will be reported when validating simple glyphs with contours with one or two
points.

Off-curve extreme coordinates

This test checks whether all off-curve points are inside the global bounding box (and
optionally their local bounding box). You can customize this feature through the Options
window.

The left image shows two red rectangles. The large one is the global bounding box and the
smaller rectangle is a local bounding box between an on-off-on curve sequence. Both off-
curve points lie outside their bounding box. With local detection enabled, the right image
shows the result of clicking the Add on-curve extremes button on the Validation toolbar.

Redundant points

This problem will be reported when validating simple glyphs with contours with redundant
points.

Duplicate knots

This problem will be reported when validating simple glyphs with contours with two adjacent
points that have the same coordinates but one is on-curve and the other is off-curve.

Intersecting coordinates

This problem will be reported when validating composite glyphs with intersecting glyph
members and when validating simple glyphs with (self-)intersecting contours. Avoid crossing
contours whenever possible.
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Note: Older PostScript Level 2 drivers do not support overlapping contours.

Contours with unknown direction

This problem will be reported when validating simple glyphs with contours that have an
unknown direction.

Contours with incorrect direction

This problem will be reported when validating simple glyphs with contours that have an
incorrect direction (Contours that need to be filled black must have a clockwise direction. If
we want to make a white area inside an existing contour we must make the direction of the
new contour counterclockwise.).

Note: This test will not be performed when Duplicate contours, Intersecting coordinates
or Contours with unknown direction have been reported.

Note: The Validation features are not available in the Home Edition of FontCreator.

5.7.2 Results

After the validation process the (remaining) problems are shown for all glyphs. Optionally the
report can be saved.

Note: The Validation features are not available in the Home Edition of FontCreator.
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5.8 Testing and Installing Fonts

5.8.1 MainType

MainType is a powerful font manager for Windows that helps you maintain your fonts.
Although its main purpose is installing and uninstalling fonts, it also allows you to insert
special characters into documents and the Test window.

You can download MainType from here:

http://www.high-logic.com/ 

5.8.2 International Keyboard

Instead of memorizing a long list of Alt number combinations, or using the Character Map,
you could change your language and layout from English-US to United States-International (or
any other available language on your system).

Here's how: 

Single-click the Start menu, mouse over Settings, and then single-click the Control

Panel. 
Double-click the Keyboard icon and then click the Language tab 

Click Add. 

Under "Keyboard layout," place a checkmark next to United States-International. 

Click OK. 

Click Apply. You may be asked to insert your Windows system disk to finish loading the

process.

You can type in other languages without knowing the Alt codes for a non-English alphabet.
For example, type ~ followed by N to get Ñ. A tilde followed by any letter will place the
appropriate accent on the letter you choose. 

5.8.3 Test Your Font

5.8.3.1 Test TrueType/OpenType

Test TrueType/OpenType font

If you want to know how your font is going to look you can test it any time during the
development process. Choose Test TTF/OTF... from the Font menu or use the hotkey F5
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You can enter your own text into the Test window. FontCreator will remember this text so you
can always test your fonts with your preferred text.

If you want to test how your font will look when it's printed you press the Print button.

Note for Windows XP users: The Test Font dialog uses a standard Window text control, that
unfortunately doesn't support Kerning and OpenType Layout Features on Windows XP.
However all modern web browsers support both so you can use the Test WOFF... option to
test them.

5.8.3.2 Test Font - Edit Text Samples

You can edit the text samples used on the test TrueType/OpenType dialog by right-clicking on
the test area and select Edit Text Samples.
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Here you can add, delete and change the order of the text-samples.

5.8.3.3 Test Web font

You can also test your font and OpenType Layout Features as a web font on a locally
generated web page. Choose Test WOFF from the Font menu or use the hotkey CTRL+F5
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If OpenType Layout Features are present, you can toggle them using the checkboxes on the
right.

5.8.4 Installing Fonts

Although it is possible to install a font through Windows fonts folder, FontCreator has its own
Font Installation wizard. To make your font available to other applications select Install in
the Font menu.

The Font Installation wizard will guide you through the installation process. At the end of the
installation process you will be informed that the font is installed successfully. Now you will be
able to select the font in any program that supports TrueType fonts.
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Note: In order to install a modified font, the font must be exported to file.
Note: It is not recommended to export font files directly into Windows Fonts folder.

Note:  If you are reinstalling the font, it is recommended you delete the font BEFORE installing
the new version.
Note: Don't just drop the font into Windows Fonts folder!
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6 Toolbars

6.1 Overview

The toolbars give you one-click access to many of the commands on the menus.
Some menu items have toolbar icons next to them so that you can quickly associate
the command with that icon.

FontCreator's toolbars can be shown or hidden as needed. By default the Standard,
Drawing, Grid, Glyph, Font Overview and the Align or Distribute toolbars are docked
below the menu bar. Choose Toolbars from the View menu to select toolbars to display or
hide, or right-click on any toolbar to get the same submenu.

The window tab bar cannot be moved or undocked. You can however close it through the 
Toolbars item from the View menu.

Tips: Toolbars can be rearranged by dragging, docked on the left, right, top, or bottom of the
FontCreator window, or made floating. In the Glyph Edit Window, to quickly close a floating
toolbar, click the Close button on that toolbar, or use its shortcut key.

To undock a docked toolbar, double-click its grab handle where the four-arrow cursor is
displayed. To dock it again, double-click the floating toolbar's title bar. The Transformation,
Validation, Preview, Background Image and Comparison toolbars cannot be docked, but
they can be toggled on/off with shortcut keys F6, F7, F8, F9, and F11 respectively.

6.2 User Notes

The User Notes toolbar can be used to write down some text that will be saved with your
project. The User notes will not be exported to your fonts.
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6.3 Transform

The Transform toolbar contains powerful tools for editing simple glyphs. Contours can be
precisely repositioned, resized, moved, skewed, scaled, rotated, or mirrored. Nodes can be
repositioned or moved by precise increments. The glyph's bearings can also be set.

The Transform toolbar can be toggled on and off using the F6 shortcut key, but is only
available in the Glyph Edit Window.

6.4 Glyph Properties

6.4.1 Glyph Properties

The Glyph Properties toolbar provides a quick way to view and edit some of the most
common glyph properties.
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Glyph Name

The Glyph Name of the glyph. Press the Generate Name button  to let FontCreator fill in
the field.

Code-points

The code-points assigned to this glyph. Press the Select Unicode Character button  to
select a character from the Unicode Character list. Press the Generate Code-point button

 to let FontCreator fill in the field automatically. It is possible to enter multiple code points
by separating them by commas, but it's common to have only 1  character mapped to each
glyph.

Unicode name

The Unicode name of the first code-point

Left Side Bearing

The (horizontal) start position of the glyph.

Right Side Bearing

The (horizontal) end position of the glyph.

Advance Width

The width of the glyph and its surrounding space.

Offset

The horizontal offset between x=0 and the Left Side Bearing
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Tip: You could also adjust the Left Side Bearing and Advance Width in the Glyph Edit
window, by changing the vertical bearings.
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6.4.2 Select Character

The Select Character dialog provides a quick way to change a character mapping. This
dialog is available through the Glyph Properties tool window by clicking the Select

Character button .

6.5 Validation

Use the Validation toolbar to locate and solve common glyph problems. It can be toggled on
and off using the F7 shortcut key (or Show glyph validation report button on the Glyph
toolbar), but is only available in the Glyph Edit window.
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Note: Because the validation can be very time-consuming, real-time glyph problem detection
will be disabled for too complex glyphs. The limits for real-time glyph validation are set on the 
Validation tab of the Options dialog.

Red marks in the Glyph Edit window will show the position of the located problems.

Not every problem should be classified as an error, it is the designer's decision to correct or
ignore potential problems. Double-click on a reported problem to focus the problematic point
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or contour. There are several buttons on the Validation toolbar that will perform actions that
will automatically solve some specific problems.

Enable real-time glyph problem detection

Use this button to enable and disable real-time glyph problem detection.

Refresh

When real-time validation is not enabled, use this button to revalidate the glyph.

Save report

Use this button to save the report to file. 

Show intersecting components and contours

Intersections will be shown when this button is enabled and is down. Red crosses in the 
Glyph Edit window will show the position of the intersections.

Show warning points

Warning points will be shown when this button is enabled and is down. Red bullets in the 
Glyph Edit window will show the position of the located problems.

Correct contour directions

Use this button to correct the direction of all misoriented contours in a simple glyph. This
button is only enabled when contour direction problems are detected.

Note: This test will not be performed when Duplicate contours or Intersecting
coordinates have been reported.

Remove duplicate components and contours

This button will remove duplicate components from a composite glyph and will remove
duplicate contours from a simple glyph.

Remove empty components and contours with one and two points

This button will remove empty components from a composite glyph and will remove contours
with one and two points from a simple glyph.

Remove redundant points

Press this button to remove all redundant points.

Note: This feature won't remove duplicate knots as this would affect the outline.

Add on-curve extremes

Press this button to add on-curve extremes. This feature will add global or local extremes, as
customized through the Options window.

Note: As this feature generates new points, this could lead to new redundant points.

Note: The Validation features are not available in the Home Edition of FontCreator.
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See also:

Font Validation

6.6 Preview

While editing a font, you can preview the results with the Preview toolbar. You can choose a
standard text sample from the drop-down list or enter your own text. It can be toggled on and
off using the F8 shortcut key and is available in both the Font Overview window and the
Glyph Edit window.

Selected glyphs in the overview window can be displayed in the Preview toolbar by pressing
the "P" shortcut key.

Change the value of the Font Size field to change the size of the text. Check the kerning box
to include kerning support. The Preview toolbar can be resized to show more text.

6.7 Background Image

You can add a background image on a Glyph Edit window through the Background toolbar.
It can help you with your glyph design. It can be toggled on and off using the F9 shortcut key,
but is available only in the Glyph Edit window.
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Click the Copy from current glyph button to place a copy of the current outline as
background image. To add a background image paste an image from the clipboard, or click
the Load button and select the image you want to use. Use the position and scale fields to
move and scale the image. Check the Monochrome box, to show the background image in
one color.

6.8 Comparison

You can show glyphs (with kerning) before and after the current glyph in a Glyph Edit
window through the Comparison toolbar. It can help you accurately position composite glyph
members such as diacritics and help you with aligning flowing scripts and other aspects of
your glyph design..
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6.9 Samples

The Samples toolbar provides a powerful way of adding some contours you may frequently
want to use in fonts or in glyphs. With the Samples toolbar you can drag and drop a sample
glyph to a cell on the Font Overview or Glyph Edit window. The toolbar can be docked or
floating, and can be toggled on and off using the F12 shortcut key.

Note: When you drop a sample onto a composite glyph on the Font Overview window it will
be converted to a Simple Glyph first.
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You can change the samples by making a special samples font, which includes your own
samples. From the Tools menu you go to Options and go to the Samples page. Here you
can select the font filename to be used in the Samples toolbar.

6.10 Color Glyph Members

The Color Glyph Members toolbar gives you a quick overview of the glyphs used in a color
glyph and allows you to add and remove glyphs. When glyph members overlap then the order
in which they appear becomes important. You can change the glyph member order by using
the Move Up and Move Down buttons.
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6.11 Palette

The Palette toolbar allows you to edit the palettes and the colors used in your font.
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The palette drop down list shows the active palette. You can add and/or remove palettes by
clicking the + and - buttons. Note that there must be at least 1 palette.

The foreground and background color selectors allow you to set the fore- and background
colors that will be used in FontCreator's Glyph Edit windows, Preview toolbar and Font
Overview. Note that each palette has it's own fore- and background colors.

The Palette entries list the current available colors for the active palette. You can modify a
color by selecting the color and using the sliders, edit fields or the color chooser. Use the  but
Apply button to process the changes. You can use the + and - buttons to add or remove
colors. Note that only unused colors can be removed.

The Foreground palette color is a special color that depends on the font color that the user
or host application has set as active font color.
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7 Customizing FontCreator

7.1 Options

7.1.1 General

You can customize the way fonts are loaded, saved and shown with the Options window
(Select Options from the Tools menu). 

Use the fields on the General page when you want to change the welcome dialog, the
interface settings or the Sample Toolbar font.

7.1.2 Overview

On the Tools menu, click Options, and then click the Overview tab. Here you can adjust
the Font Overview settings.
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Show sample in empty glyphs

Will show a grey sample glyph for empty glyphs in the font overview. You can change the font
to use by selecting one from the installed fonts list.
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7.1.3 Glyph

On the Tools menu, click Options, and then click the Glyph tab.

Here you can set the way a Glyph Edit window will show the glyph and how Vector Based
Images are imported.



FontCreator Help122

© 1997 - 2013 by High-Logic B.V. All rights reserved.

7.1.4 Naming

On the Tools menu, click Options, and then click the Naming tab.

Default  Naming for New Fonts

These fields are used as initial naming fields when a new font is created. <year> will be
replaced by the current year and <font family> will be replaced by the actual font family name.
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7.1.5 Validation

On the Tools menu, click Options, and then click the Validation tab.

The Real-time glyph validation settings are used to determine whether the real-time glyph
problem detection should be disabled as it would be too time consuming. These settings are
only used by the real-time glyph problem detection. When disabled, use the Show glyph
problem report to open the Glyph Problem Report window.

Off-curve extreme coordinates detection can be performed global or local.

Note: The Validation features are not available in the Home Edition of FontCreator.

See also:

Font Validation
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7.1.6 Advanced

On the Tools menu, click Options, and then click the Advanced tab.

Warn before executing Glyph Transformer script

This indicates and determines if a warning will be issued when the Transform wizard is
finalized. If this is not checked, no warning will be given.

Warn when opening 10 or more fonts

This indicates and determines if a warning will be issued when opening 10 or more fonts.
Opening a lot of fonts at the same time will require a lot of system resources.

Create backup copy (bck) on saving a font project

Copies the previous version of a font project as a backup copy every time you save a font
project. Each new backup copy replaces the previous backup copy. FontCreator saves the
backup copy (with a file name extension .bck) in the same folder as the original.

Check for updates

Set the interval that FontCreator uses to check for updates. An interval of Once a week will
ensure you are always working with the latest version of FontCreator.
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7.2 Grid Options

You can adjust the way the grid in the Glyph Edit window is drawn in the Grid Options
window (select Grid Options from the Tools menu).

Here you can change the minimum distance, color and style.

The Snap to Grid function automatically places selected glyphs, contours and points along
the grid. When you release a selection, FontCreator moves it until the edges are aligned with
the nearest grid lines. 

You must choose the Show Grid command before you can use the Snap to Grid function. To
activate the Snap to Grid function, click the Snap to Grid button on the toolbar or choose
Snap to Grid from the View menu.

When the Snap to Grid function is active, its button on the menu and toolbar appears pressed
in. Choose the command or click the button again to turn off the function.

Note: Grid options are project specific. This means you can have different grid settings for
each of your projects.

7.3 Metrics Options

To open the Metrics Options window click Metrics Options on the Tools menu. Here you
can specify what metrics and reference lines should be shown in the Glyph Edit window.
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Note: Metrics options are project specific. This means you can have different metrics
settings for each of your projects.

See also:

Glyph Metrics

7.4 Guidelines

7.4.1 Options

To open the Guidelines Options window click Guidelines Options on the Tools menu.
The Guidelines Options window is also activated when you double-click the rulers in the
Glyph Edit window.
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Here you can show and hide the guidelines, and change the guidelines style and color.

The Snap to Guidelines function automatically places selected glyphs, contours and points
along the guidelines. When you release a selection, the FontCreator moves it until the edges
are aligned with the nearest horizontal or vertical guidelines. It is also possible to snap
points to diagonal guidelines. You must choose the Show Guidelines command before you
can use the Snap to Guidelines function. To activate the Snap to Guidelines function, select
the Snap check box, click the Snap to Guidelines button on the toolbar or choose Snap to
Guidelines from the View menu. Select the Lock check box, or select the Lock Guidelines
button on the toolbar,  to prevent accidental movement of the guidelines.

Press the New button to define a new guideline. Press the Modify button to modify an
existing guideline. To delete an existing guideline select it from the list view and click the 
Delete button. Use the Clear button to remove all guidelines.

If you want to add a horizontal or vertical guideline you can drag one from the top or left-hand
ruler in the Glyph Edit window. Hold down the left mouse button and release it after you have
moved the pointer to the desired position. To remove a guideline, simply drag it back to the
ruler.

In order to rotate a guideline, press and hold down the Shift key before moving the guideline.
Rotating a horizontal or vertical guideline will change the guideline into a diagonal guideline.
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Select one or more contours (or one ore more composite glyph members) and right-click and
then select Add Bounding Guidelines to add two horizontal and two vertical guidelines that
correspond to the selection bounding box.

To copy a guideline to a new position, hold down the Ctrl key as you drag the guideline.

Tip: Select two points in a Glyph Edit window and press the G key on your keyboard to add a
guideline that goes through the selected points.

Note: User defined guidelines are project specific. This means you can have different user
defined guidelines for each of your projects.

7.4.2 Guideline

Use the Guideline window to create or modify guidelines.

Line Type

Choose between horizontal and vertical lines and two diagonal line types.

Line Position

Both horizontal and vertical lines only need one value.

A diagonal line needs either one point with an angle or two points.
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Tip: The Guideline window is activated when you double-click a guideline in the Glyph Edit
window.

7.5 Keyboard Shortcuts

You can quickly accomplish tasks you perform frequently by using shortcut keys — one or
more keys you press on the keyboard to complete a task.

General Shortcuts

Press To

Ctrl+Tab (or Ctrl+F6) Next Window

Ctrl+Shift+Tab Previous Window

F1 Help

F2 Show/Hide User notes Toolbar

F3 Glyph Properties Toolbar

F4 Show/Hide Statusbar

Ctrl+F4 Close Window

F5 Test Font as TTF/OTF

Ctrl+F5 Test Font as WOFF

F6 Show/Hide Transform Toolbar

Ctrl-F6 Launch MainType

F7 Show/Hide Glyph Validation Toolbar *

F8 Show/Hide Preview Toolbar

F9 Show/Hide Image Toolbar

F10 Activates the Main Menu

Shift-F10 Displays the shortcut menu for a selected item

F11 Show/Hide Comparison Toolbar

Ctrl-F11 Launch Windows Font Folder

F12 Show/Hide Samples Toolbar

Ctrl-F12 Launch Windows Character Map

Delete Delete selection

Ctrl-A Select All

Ctrl-C Copy
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Ctrl-E Paste Special

Ctrl-F Displays the Find dialog box

Ctrl-I Open Installed Fonts

Ctrl-J Display values as Hexadecimal

Ctrl-K Display values as Decimal

Ctrl-N New Project

Ctrl-O Open Project

Ctrl-P Print

Ctrl-R Repeat

Ctrl-S Save Project

Ctrl-T Invert Selection

Ctrl-U Clear Selection

Ctrl-V Paste

Ctrl-X Cut

Ctrl-W Close current tab

Ctrl-Y Redo

Ctrl-Z Undo

Ctrl-Shift-E Export font as TrueType/OpenType font

Ctrl-Shift-W Export font as Web Open Font Format (WOFF) font

Ctrl-Shift-A Export font in all formats

Keys for working in the Glyph Overview window

Press To

Enter Open Glyph Edit window

Backspace Clear selected glyphs

P The first 256 characters mapped to the selected glyphs will
be placed into the preview toolbar

Ctrl + Plus Sign Increase the cell size

Ctrl + Minus Sign Decrease the cell size

Ctrl + Shift + Plus Sign Increase character size
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Ctrl + Shift + Minus Sign Decrease character size

Ctrl + 0 Reset character and cell size to their defaults

Keys for working in the Glyph Edit window

Press To

Plus Sign or Ctrl+Plus Sign Increase the zoom factor

Minus Sign or Ctrl+Minus Sign Decrease the zoom factor

Ctrl + 0 Reset zoom factor to default

Alt+Left Arrow Go to previous glyph

Alt+Right Arrow Go to next glyph

N Change selected points to on curve

F Change selected points to off curve

G Add guideline through two selected nodes, or add
orthogonal guidelines at a single selected node

A Add points after selected points

H While pressed down, hides everything except the glyph

Q Select previous contour/point index or composite glyph
member

W Select next contour/point index or composite glyph member

/ Fit to Window

Space+Left mouse button Move around the Glyph Edit window

Double-click While editing an empty or simple glyph, this will switch
contour/point mode

While editing a composite glyph, this will open the
composite glyph member properties window

Double-click on rulers Edit guidelines

Double-click on guideline Adjust guideline

Shift-click on guideline Rotate guideline

Ctrl+Drag guideline Duplicate guideline

Click on selected contour show/hide rotate and skew handles

Shift+Mouse Constrain movement and scaling



FontCreator Help132

© 1997 - 2013 by High-Logic B.V. All rights reserved.

Ctrl+Mouse Duplicate selected contour

You can reset all toolbar positions and sizes by pressing the Ctrl key while starting
FontCreator.

* Not available in the Home Edition of FontCreator.
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